document.write loop hangs browser. See also #112858

VERIFIED WORKSFORME

Status

SeaMonkey
Installer
--
critical
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: David DelGreco, Assigned: dveditz)

Tracking

({hang})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
I'm using gtchat (http://www.gtchat.de), which is a Javascript-implemented chat room.  It works great in IE and used to work in Mozilla 1.1.  I upgraded to 1.2b and found that after logging into the chat room, the browser would hang.  After ending the Mozilla process, Mozilla would no longer start.

I uninstalled 1.2b and resinstalled 1.1, but the same thing happens now.  After uninstalling 1.1 and manually deleting all traces of Mozilla from the registry, then reinstalling 1.1, it functioned again.

I didn't write the Javascript, so I can't tell you exactly where to look, but I can provide you the script if you need it.  I suspect it is related to bug #112858, which cites a document.write loop problem.

Comment 1

16 years ago
Reassigning to Browser-General until we can get further information.
This is not likely to be a JS Engine bug. Cc'ing self.

Dave: 

1. When I try to go to the URL you've provided above,
   http://delatore.com/gtchat/chat.pl, I get a 404 Error - Not Found.
   Is there a typo?

2. Do we need a login to enter the site? If so, could you set up
   a test account for us, say with these parameters:

                 UserID = mozilla
                 Password = bugzilla

3. After logging in, are there any steps to reproduce the hang?
   Or do we just hang as soon as we log in?

4. What happens if you launch Mozilla like this, from a console:

         [(path to Mozilla)]./mozilla -profilemanager

   Once the Profile Manager comes up, click on "New Profile".
   I'm wondering if this is a profile-related problem, and that 
   the hang will go away once you run Mozilla under the new profile.


Of course, if 4. fixes the problem, answers to 1. - 3. will not
be needed!
Assignee: rogerl → asa
Component: JavaScript Engine → Browser-General
Keywords: hang
QA Contact: pschwartau → asa

Comment 2

16 years ago
WFM Win 2000 2002102704.  Test account created as suggested in Comment #1. 
Correct URL is http://delatore.com/gtchat/ so I chenged it in the description. 
Reporter, you might also try a nightly and see if it still happens.

Comment 3

16 years ago
Note: for some reason I can't get back in with the mozilla/mozilla...  but you
can easily re-register on the page for testing.
(Reporter)

Comment 4

16 years ago
1) You found the right URL.  Sorry.  I mentally mixed up the load page with the cgi-bin.  Either http://delatore.com/gtchat or http://delatore.com/cgi-bin/gtchat/chat.pl will work.

2) I created a mozilla/bugzilla account, then got the update that someone had already created a mozilla/mozilla account.  I changed the password back to mozilla....

3) Anything else I goofed up?  It's been a funny day.  :-)
(Reporter)

Comment 5

16 years ago
Phil,

Tried creating a new profile. Interesting results:

I booted the computer just now, but Mozilla would not start. I
had to kill the .exe manually. Without rebooting, I tried your
suggestion and created a new profile, "Cool Guy", and now
Mozilla is working fine. I may have done the bad thing and made
an assumption over a coincidence of timing.

I started testing the chat room with Mozilla 1.2b this week
That's when the hanging problems started. Once it started, I
couldn't seem to get it to behave, so giving specifics to
reproduce was difficult.

BUT, now that you've called my attention to it, I installed a
couple of themes the same day I started testing 1.2b. I believe
if I reinstall some themes, I'll get Mozilla hanging again.

Currently, themeless, Mozilla works with the chat room
just fine.

Shamed,
Dave

Comment 6

16 years ago
Dave: thanks, that is valuable info!!! Let us know if the new themes
are causing the problem, then - or perhaps it was just a corrupt profile. 
Unfortunately, that sometimes happens -
(Reporter)

Comment 7

16 years ago
Further testing:

Today, Moz wouldn't start again. I killed the .exe, uninstalled, and
reinstalled Moz 1.2b. It still won't start.

I uninstalled, removed the mozilla.org folder, then purged the registry of
numerous left over items. THEN I reinstalled. No problems.

For the last three hours, I've installed mouse gestures, I use tabbed
browsing, and I've installed several themes (Internet Explorer (which won't
uninstall), Pinball, and Lo-Fi Classic). I've run my chat room in multiple
tabs, and no problems have arisen. I cannot reproduce the results I was
getting over the last week.

In reading FAQ's etc., I read something that said never to install one version
of Moz over another. I had, in fact, installed 1.2b over 1.1. Could that be
the problem? If so, I hope this doesn't mean profiles, bookmarks, etc. need to
be deleted to upgrade. Uggghhh-ly.

Anyway, if further results come up, I'll add to this.

Dave

Comment 8

16 years ago
> In reading FAQ's etc., I read something that said never to install one version
> of Moz over another. I had, in fact, installed 1.2b over 1.1. Could that be
> the problem? If so, I hope this doesn't mean profiles, bookmarks, etc. need to
> be deleted to upgrade. Uggghhh-ly.

Let me reassign to the Installer component for an answer to that.
Dave: thanks again for testing this so thoroughly!
Assignee: asa → dveditz
Component: Browser-General → Installer
QA Contact: asa → bugzilla

Comment 9

16 years ago
the installer problem:
remove entire mozilla.org directory and reinstall mozilla
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 10

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.