If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

quip.co.uk - fails to display some data

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
15 years ago
11 years ago

People

(Reporter: Michael Graubart, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2b) Gecko/20021029
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2b) Gecko/20021029

Alternative ways of getting to the same point are <http://natwestcaller.com> and
<http://www.natwest.com/scripts/framenav.asp?CARDS/MAIN/OFFERS&/bus_cards/personal/cards/caller.htm>

This is a telephone system which allows bills and call-details to be viewed
online. Using Netscape 4.79, everything works fine. Using Mozilla, most parts of
the site work, but 'Your Call Reporter' opens, shows the number of calls listed,
but shows no further details.

Reproducible: Always

Steps to Reproduce:
1.Open the site.
2.Click 'Members Log In'.
3.Fill in details (mine are: Account Number 34655504, PIN number 1685; Password
(if required) Cerberus. NB: These are confidential!)
4.Click 'Your Call Reporter'.

Actual Results:  
The Call Reporter page opens, shows the number of calls currently listed and the
number of pages of details, but no details. (If this is repeated, using Netscape
4 or Internet Explorer instead of Mozilla, at this point several pages of
details of calls made, with date, time, number calling, number called, duration
and charge appear.)

Expected Results:  
Several pages of details of calls made, with date, time, number calling, number
called, duration and charge should appear.

Mac G3 (old beige).  OS 9.2.2.  Modern theme.
(Reporter)

Comment 1

15 years ago
Further to this report, I see that I put 'http;//' too many times. The website
URL is just: <http://www.quip.co.uk/>

Also, I have tried it with the Classic theme also, and the result is the same.

Comment 2

15 years ago
Michael, your account information is now publically visible on this site. I
recommend you change them ASAP and only provide them on private request by a
Mozilla developer.
(Reporter)

Comment 3

15 years ago
This bug is still present in Build No. 2002103113.

Comment 4

15 years ago
From bug 177892:

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2b) Gecko/20021031
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2b) Gecko/20021031

This report basically duplicates Bug No. 177737, but I have failed in my attempt
to change 'Text Evangelism' to 'Browser' and 'Unconfirmed' to 'New'. Please see
No. 177737 for details, but add the following:

1. I should not have publicized my account details. I have, therefore, changed
them. If a developer wants the new ones in order to view the fault on the data
display on the website, would s/he please e-mail me.

2. I have marked the 'Product' as 'Browser' this time, because I discovered
(after filing Bug 177737) that Build No. 20021017 displayed everything correctly.

3. The bug is still present in Build No. 2002103113.
Assignee: nitot → asa
Component: Europe: West → Browser-General
Product: Tech Evangelism → Browser
QA Contact: brantgurganus2001 → asa
Version: unspecified → other

Comment 5

15 years ago
*** Bug 177892 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
Hmm... I'm not sure if this is related but I found another thing thats not
visible on this site. With IE5.1 (Mac OS 9.1) I see a continue-link in the lower
green field at https://www.quip.co.uk/join/index.asp.

But with my old Mozilla build 2002091014 (Mac OS 9.1) the link (they call it
"continue-button") is not there. I can't join their service... Someone else
might confirm (using an old build).

Comment 7

15 years ago
Sorry about the spam but: Obviously the link is there - it's just not visible in
Mozilla.
(Reporter)

Comment 8

15 years ago
I have not tried this with an earlier build, but I have checked Stefan Hermes'
comment using Build No. 2002101703 (with which the Call Reporter, which did not
show data in Builds 20021029 and 20021031, appeared correctly). It is quite
right. No 'Continue' button or 'Send' button (which is referred to later if one
does move on) can be seen. 

If, however, one clicks on the green field itself near the bottom of the window,
one goes on to the next window in the desired manner. So it is not the function
that is inhibited, but just the appearance of the button.
(Reporter)

Comment 9

15 years ago
This bug is still present in Build No.2002110708. As it is NOT present in Build
No.20021017, it must be a fault in the later Mozillas, not in the web-site. It
should be fixed urgently, please.
(Reporter)

Comment 10

15 years ago
I reported earlier that in Mozilla Build No.20021017 the 'Call Reporter' works
correctly. I have now discovered that this is not strictly true. In Build
20021107, the Call Reporter shows no data. In Build 20021017, it displays the
data, but does not sort them correctly (e.g. by date). (In Netscape 4.79, it
sorts them correctly.)

I repeat that if a developer wants to try this, I will give him/her my account
details on receipt of an e-mail.
(Reporter)

Comment 11

15 years ago
I am still not clear whether this is a Mozilla bug or a fault in the web-site.
But if it is the latter, I wonder if someone could explain to me why Netscape 4
(and Internet Explorer) are tolerant of variations in web-site design, while
Mozilla (I am now on Mozilla 1.2.1) has been made so intolerant? It means that
one has either to revert to using the older browsers, or to have both the older
ones and Mozilla available.
(Reporter)

Comment 12

15 years ago
I have corresponded with QUIP about this. The only answer that I got from their
web-site person was that it works correctly with Internet Explorer – which I
knew! – and that they could give me instructions about browsers settings (for
IE) – which I don't need.

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Web-site fails to display some data → quip.co.uk - fails to display some data
(Reporter)

Comment 13

15 years ago
This website has now got WORSE. In the past one could click 'Members' login' and
get to the Call Reporter (which then failed to show data). Now one cannot get
past the home page: if one clicks 'Members' login', one gets back to the home
page. The site still works OK with Internet Explorer 5.
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".
Confirmed on Windows 2000 mozilla 1.5rc1 and Linux moz 1.4 as well. 


The page at https://www.quip.co.uk/join/index.asp has a green table cell along
the bottom right. I am guessing that there should be a button there, but cannot
see it.

However, if I move the mouse pointer along this green area, the pointer changes
to a hand, and I can click the invisible link to get to the page with the
sign-up form.


The link shows up as _continue_ with IE6, Windows 2000.
Confirmed on Mac OS X as well. The continue text link never shows up, though the
link is active.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20030916

Comment 17

14 years ago
updating platform and os based on comments.
OS: Mac System 9.x → All
Hardware: Macintosh → All

Comment 18

14 years ago
The continue-button is missing because of bad coding:

The html:
<td bgcolor="#339933" align="center">
<a href="/join/contact.asp"><h1 class="down">
<u> Continue</u></h1></a>
</td>

And the css:
.down
{
FONT-FAMILY: "Verdana, Geneva, Helvetica, sans-serif";
COLOR: "#532BA5";
FONT-WEIGHT: BOLD;
}

Removing the quotation marks causes the link to be visible...

However, this has probably nothing to do with the original report. Michael, can
you reproduce the bug (lack of data) with a current OS X build?
Product: Browser → Seamonkey
Frankie (the confirmer) "probably invalid html that technically shouldn't work"
Assignee: asa → general
QA Contact: asa → general
Michael (reporter) "I have not used Quip for many years; I just went to the website and logged in and everything seemed to be working, but as there have been no calls for the Call Reporter to report, I couldn't check whether all the details were shown or not. This was with SeaMonkey 1.0.2, build of 29 June. Someone would have to sign up with Quip and make some calls and try again."

Thanks Michael. No other bug reports about quip and no testcase, so given their record of invalid html closing this as currently invalid. Please reopen if someone determines otherwise.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.