Closed Bug 1777467 Opened 2 years ago Closed 6 months ago

Add test which calls `readText()` from an `<iframe>` and its parent frame

Categories

(Core :: DOM: Copy & Paste and Drag & Drop, task)

task

Tracking

()

RESOLVED DUPLICATE of bug 1852947

People

(Reporter: mbrodesser-Igalia, Assigned: edgar)

References

(Blocks 1 open bug)

Details

Summary: Add test which calls `readText()` from and `<iframe>` and its parent frame → Add test which calls `readText()` from an `<iframe>` and its parent frame

(In reply to Mirko Brodesser (:mbrodesser) from comment #0)

Add it to https://searchfox.org/mozilla-central/rev/4654ce1e24a6af17bc96ab60f1f70c218755142f/dom/events/test/browser_navigator_clipboard_readText.js.

I would suggest making the new tests live in a separately test file to prevent a single test file contains too many different tests.
(We could put the common code into a js file, e.g. helper.js, and import it)

I am going to add tests in bug 1777448.

Assignee: nobody → echen
Status: NEW → RESOLVED
Closed: 6 months ago
Duplicate of bug: 1852947
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.