Closed Bug 1777506 Opened 2 years ago Closed 2 years ago

Pages with unsubmitted form data should (temporarily?) get high priority

Categories

(GeckoView :: General, enhancement, P1)

Unspecified
All
enhancement

Tracking

(firefox108 fixed)

RESOLVED FIXED
108 Branch
Tracking Status
firefox108 --- fixed

People

(Reporter: agi, Assigned: calu)

References

(Blocks 1 open bug)

Details

(Whiteboard: [geckoview:2022q3] [geckoview:m108])

Attachments

(1 file)

An unsubmitted form is a signal that the user is still working on the page, we should give those pages high priority on Android so that we keep them around as long as possible.

We could also have a timeout of a few minutes in case the user does not intend to return to it.

This problem will be worse with Fission when tabs can run in separate processes.

Severity: -- → N/A
Priority: -- → P2
Whiteboard: [geckoview:2022q3]

Geckoview should expose an API that returns a bool whether or not there is uncommitted form data, so that Fenix can set any GeckoSessions to HIGH priority.

Component: General → Core
Whiteboard: [geckoview:2022q3] → [geckoview:2022q3] [geckoview:m108?]

108

Assignee: nobody → calu
Whiteboard: [geckoview:2022q3] [geckoview:m108?] → [geckoview:2022q3] [geckoview:m108]
Priority: P2 → P1

Design Doc: https://docs.google.com/document/d/1rvxdfzBMu_I_qC6OY-9Rpex2kdWHGCefp1QIR2AYXl4/edit?usp=sharing

GeckoView provides an API containsFormData(), where the parent process queries the child process for any existing session form data using SessionStoreUtils and returns a GeckoResult<Boolean> whether or not there is form data.

Pushed by calu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/067c604678ba
Provide a GeckoSession API to check if the session has any form data r=geckoview-reviewers,jonalmeida

Fenix bug to use this API to increase or decrease process priority: https://github.com/mozilla-mobile/fenix/issues/27803

Depends on: 1800146
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 108 Branch
Duplicate of this bug: 1794852
Blocks: 1820211
Component: Core → General
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: