URL field does not get focus on new window AND ctrl-L doesn't work

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: mstockman, Assigned: hewitt)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021030
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021030

When I create a new browser window by clicking the Mozilla shortcut created on
the task bar (bottom-left, next to the Start button), the URL field does not
have the focus as expected.

Furthermore, control-L doesn't give the URL field the focus. I have to switch
out (alt-tab) and back in again to see the caret blinking happily in the URL
field, at which point I can type a URL as I wanted to do in the first place.

I've verified this for a number of builds back, although it used to work fine.

My prefs are set to home page=about:blank, and When Navigator Starts Up opens
blank page (although changing this to home page didn't change anything).

This doesn't appear to be the same as any of the *other*
URL-field-doesn't-get-focus-when-expected bugs, but I could be wrong.

Reproducible: Always

Steps to Reproduce:
1. Click shortcut button on task bar (next to Start button)
2. Notice that URL field doesn't have focus, and typing has no affect.
3. Hit control-L. Notice same as (2).
4. Alt-tab out, and back in again. Notice how URL field caret is blinking.



Expected Results:  
Put the focus into the darn URL field when the browser window opened with no
darn content.

Comment 1

16 years ago
When a new window is open the focus seems to be on the document. Though CTRL + L
works fine for me.

Comment 2

16 years ago
Ctrl+L works for me on 20021130 on WinXP.

Mike, do you still have this problem on a new build?
(Reporter)

Comment 3

16 years ago
Yup, this problem occurs exactly as described on my Win2K machine, build
2002120204. I've removed my profile and recreated it just to be sure it's not a
configuration/prefs issue, but it still happens. Kind of a pain...

Comment 4

16 years ago
I can verify this on Mozilla 1.3a, Win98SE (Mozilla/5.0 (Windows; U; Win98;
en-US; rv:1.3a) Gecko/20021216). This is a fresh install, with a fresh user profile.

I open mozilla, then open another (by running mozilla.exe twice), with a blank
page set as my homepage. In the second window, the URL field doesn't have focus,
and Ctrl-L doesn't work. When I switch to another window and back, the URL field
has focus and a cursor, and everything works as expected. The problem doesn't
occur when a non-blank homepage is set. In that case, the document has focus,
but Ctrl-L works.

Comment 5

16 years ago
->URL bar
Assignee: asa → hewitt
Component: Browser-General → URL Bar
QA Contact: asa → claudius

Comment 6

16 years ago
Confirming using build 2003012804, Windows 2000.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

16 years ago
Confirming bug on WinXP SP1 machine with both Mozilla 1.2.1 and 1.3b.  As has
been stated before, this bug does not occur when the homepage is set to
something besides blank.

Comment 8

16 years ago
Confirming this Bug on Mozilla 1.3b, Windows 2000 SP3.

Reproducable under any of the following conditions:

- 'blank page' radio button is selected in the navigator preferences
  (browser.startup.page=0)

- 'home page' radio button is selected and location is set to about:blank 
  (browser.startup.page=1, browser.startup.homepage=about:blank)

Note that this bug doesn't occur when a new mozilla window is opened from an
existing mozilla window (for example by hitting CTRL+N).

So the only way for me to reproduce this is :

launch mozilla.exe
launch mozilla.exe again

This situation seems to cause a few more bugs, not sure if they should be filed
elsewhere or here. For instance the following keyboard shortcuts cannot be used
withhin the new window:
CTRL+Q,CTRL+W,CTRL+B,CTRL+H and obviously CTRL+L

Although I haven't tested this thoroughly enough I wouldn't be surprised if
almost no CTRL combinations work in the second window.

Comment 9

16 years ago
I'd like to clarify my comment by saying that my situation is exactly as #8
stated.  

Also, along the same lines, I've found that if -turbo is being used, the same
result occurs even when first launching the browser, because Mozilla is already
in memory.

Sidebar: I'd like to enable the Mozilla quicklaunch for the speed benefit. 
However, because I launch mozilla using only the keyboard, it's frustrating to
have to reach for the mouse to focus the URL bar.

Comment 10

16 years ago
Should this bug block 55416 ([meta] Location bar focus issues)?

Comment 11

16 years ago
I've seen this behavior too (btw, it's still present in 1.4a), but I don't use
about:blank as my start page.  My start page is a local file on my hard drive. 
Perhaps it happens with any local file?

Comment 12

16 years ago
Confirming with Mozilla 1.3 release version/Win2k.

Updated

16 years ago
Severity: normal → major

Comment 13

16 years ago
I've noticed that occasionally, the symptoms described DO NOT happen.
I just figured out the conditions under which this occurs, after
visiting this Bugzilla page.

1) Open a new browser window.
2) Visit a page that contains one or more input form fields.
3) Click in one of the form fields
4) Close the window
5) Click the Mozilla shortcut in the taskbar

This new window will have the focus in the URL bar as desired. Weird.

Comment 14

16 years ago
Appears to be fixed in 1.4b

Comment 15

15 years ago
Appears to be fixed in 1.5 release / win32.

Comment 16

15 years ago
-> WFM per user comments.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.