only 1 of 4 frames displayed

RESOLVED INVALID

Status

()

Core
Layout: HTML Frames
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: Rich Coe, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

MS frontpage hogwash

See attached file.

banner.htm displays, but menu/tree.htm, menu/search.htm, and content/Content.htm
do not.

Can specify the individual .htm files and load ok.
Suspect MS non-standard output to blame. 


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

16 years ago
Created attachment 104779 [details]
html which shows the problem
  <frameset frameborder="0" border="0" scrolling="AUTO" cols="*">
     <frame src="banner.htm" scrolling="NO" name="banner">
     <frameset cols="280,*">

That markup should show the banner only, not the frameset (since you specified
that there be only _one_ column).

Of course you specified two rows for the outermost frameset but never provided a
second row...

Summary:  A </frameset> is desperately missing somewhere.  _I_ can't tell where,
so there's no way in hell the parser could...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

16 years ago
I can't even see the source in the attachment, perhaps it's munged ?

<!-- Sample HTML file -->
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<head>
  <meta name="GENERATOR" content="Microsoft FrontPage 4.0">
  <meta name="ProgId" content="FrontPage.Editor.Document">
  <meta http-equiv="Content-Style-Type" content="text/css">
  <title>Global Software Platforms</title>
</head>
<frameset frameborder="0" border="0" scrolling="AUTO" rows="160,*">
  <frameset frameborder="0" border="0" scrolling="AUTO" cols="*">
    <frame src="banner.htm" scrolling="NO" name="banner">
    <frameset cols="280,*">
      <frameset rows="*,200">
        <frame src="menu/tree.htm" name="navigate" scrolling="AUTO">
        <frame src="menu/search.htm" name="search" scrolling="NO">
      </frameset>
      <!--
      <frame src="menu/navigate.htm" name="navigate" scrolling="AUTO">
      -->
      <frame src="content/Content.htm" name="contents" scrolling="AUTO">
    </frameset>
  </frameset>
  <noframes>
    <body bgcolor="#FFFFFF">
    <p>To view this page, you need a browser that supports frames.</p>
    </body>
  </noframes>
</frameset>
</html>
Perhaps what is munged?
You need to log in before you can comment on or make changes to this bug.