Closed Bug 1777670 Opened 2 months ago Closed 1 month ago

TB 102 LTS - GUI not fully translated

Categories

(Thunderbird :: Build Config, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr102 fixed)

RESOLVED FIXED
104 Branch
Tracking Status
thunderbird_esr102 --- fixed

People

(Reporter: marcoagpinto, Assigned: rjl)

Details

Attachments

(3 files)

Hello!

Many parts of the GUI of the release aren't translated in the Portuguese (pt-PT) version.

For example, the menu option “OpenPGP Key Manager” is in English.

And the radio buttons in the import/export are also untranslated.

Blocks: tb102found

Please try 102.0.1 which will be out soon.

No longer blocks: tb102found
Component: General → Build Config
Flags: needinfo?(marcoagpinto)
Flags: needinfo?(marcoagpinto)

@Wayne, see the screenshots in 102.0.1 build 2.

Many untranslated things.

@Wayne

I was stressed, but I am almost 100% sure that I downloaded from the build2 folder.

Flags: needinfo?(marcoagpinto)

Confirmed in TB 102.0.1-build2. The string is translated in Pontoon, and l10n-changesets.json is pinned appropriately. I'm not sure why it wouldn't be getting translated.

Some more notes...

I'm mostly looking at the OpenPGP Key Manager menu item. It's not translated on Daily either. It should be.

I noticed some errors in the jsconsole about missing .ftl files. Playing a hunch, I created empty versions of those files (ala bug 1586984) in omni.ja. That didn't seem to help the menu bar, but it did fix the translation of "OpenPGP Key Manager" in the hamburger menu.

Bug 1586984 and associated bug 1464156 and bug 1743659 are all closed out now, suggesting that there's no need to create empty .ftl files. So, I'm still not sure what's going on.

The important thing to extract from all of that is that the issue is reproducible on Daily. I suspect that something is wrong in the code for the menu items causing this to happen.

For comparison purposes, I checked the es-MX build. Everything looks fully translated.

Flod, Is this a matter of needing to create empty .ftl files? As I mention above, that seemed to help with the hamburger menu at least. (But then why is that happening? Do we need to do something for bug 1743659 to work?)

There is also one error that shows up for pt-PT when I run compare-locales.

Flags: needinfo?(francesco.lodolo)

If you're loading 10 files in the HTML head, and 1 is not available, everything will fall back to en-US (I can't tell if that's the case here without knowing what the code involved is). That's how Fluent works.

I can run a script to add missing FTL files for Thunderbird tomorrow, but you'll need to update l10n-changesets in release to fix it for 102.

P.S. I also won't be around for the next ~10 days

Flags: needinfo?(francesco.lodolo)

(In reply to Francesco Lodolo [:flod] from comment #11)

I can run a script to add missing FTL files for Thunderbird tomorrow, but you'll need to update l10n-changesets in release to fix it for 102.

Thanks, hopefully that will work. I plan to repin l10n-changesets.json for the next few 102 releases since we had so many late string additions.

I've actually run the script already
https://hg.mozilla.org/l10n-central/pt-PT/rev/3ea7e559b0154793e36dab1f990495d8c13fc851

With that said, I would point out that there are quite a few strings missing, so a certain level of English content is expected
https://pontoon.mozilla.org/pt-PT/thunderbird/

I ran a build of 104.0a1 now that empty files FTL are present. That fixed up the "OpenPGP Key Manager" string in the menus.

The Import Tool is not fully translated for pt-PT, so that part of this bug is invalid.

I'll leave this open until 102.0.2 builds as I will update to latest l10n-changesets and fix what can be fixed.

Flags: needinfo?(rob)
Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Flags: needinfo?(rob)
Resolution: --- → FIXED
Assignee: nobody → rob
Target Milestone: --- → 104 Branch
You need to log in before you can comment on or make changes to this bug.