bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Cannot select entries from drop-down-box with keyboard




Keyboard: Navigation
16 years ago
14 years ago


(Reporter: Bernd Wurst, Assigned: Aaron Leventhal)


Windows XP

Firefox Tracking Flags

(Not tracked)




16 years ago
With release of 1.2a (IIRC) there was that change that Windows-default-controls
are used for displaying form-controls in websites.
But since that change, I'm no longer able to select an enry from a drop-down-box
with keyboard. I always have to use the mouse!
I do not really understand that behaviour, because windows-default ist able to
be used with keyboard and mozilla-1.1 also was.

Has also anyone that problem? If this is a general 1.2-problem, I think it's a
major bug, because "type-ahead-find" is just for putting away the mouse.

Comment 1

16 years ago
Are you talking about drop downs in the UI (in dialogs) or in web pages?
Assignee: form → aaronl
Component: Layout: Form Controls → Keyboard Navigation
QA Contact: tpreston → sairuh

Comment 2

16 years ago
in web-pages.

Comment 3

16 years ago
Can you update to a build from today and see if it's stil a problem?

Also, I didn't understand your comment about type ahead find. What does that
have to do with this bug?

Let's say you drop down a box (with Alt+Down or Alt+F4)

What happens if you type "B"?

- Aaron

Comment 4

16 years ago
Sorry, I mean Alt+down or F4 to drop it down. Not alt+f4!

Comment 5

16 years ago
Sorry for my bad english! ;-)

That comparison with type-ahead-find is just to underline the "major"-severity.
I do not want to use my mouse too often. It doesn't really have to do anything
with that!

I'm sorry, I will try to update to a nightly bulid as soon possible but not today.

The behaviour with my (normal 1.2b build) Mozilla would be as follows:
Pressing "B" doesn't do anything.
If the Box is opened with the mouse pressing "B" will also do nothing. But then
I'm able to navigate with cursor-keys (only if it's open!). But I'm still not
able to select an entry with the keyboard. Pressing "space" does nothing,
pressing "Enter" resets the box to the value it has been before.

Hope that helps.

Pressing Alt-F4 closes Mozilla. *SCNR*
F4 does nothing.
Alt-Down also does nothing.

By now I think it has to be a local problem. Does all that stuff work for you on
any windows-machine? ;-)

Comment 6

16 years ago
Don't know what my computer does with mozilla but now it's as follows:

My desktop-pc on Windows XP Prof. does as described above. And it does not
change anything to reboot or something like that!

My laptop with new-installed Win2K Prof. and also Mozilla 1.2b does as expected.
On that machine, it workes fine.
So ist has to be either a local problem with my special config or it's XP
specific for any reason.

I don't know what it is, but if noone else with Windows XP has this problem, you
can mark as WFM. I don't know why it does not work on my machine...

Comment 7

16 years ago
Have you tried it on several different web pages?

Comment 8

16 years ago
yes, of course. ;-)
several plain-HTML, JS-featured and so on. 
On laptop -> everything works, desktop -> doesnt.

Comment 9

16 years ago
It could be an XP-specific problem then.

Comment 10

15 years ago
Reporter (Bernd): Can you reproduce this bug with a recent build of Mozilla (for
example, 1.3a)? If so, then please comment again with details. If not, then
please resolve this bug as WORKSFORME. Thanks.

Comment 11

15 years ago
Yes, it's still reproducable with 1.3a.
I said, possibly my system is little damaged, but I am not able to select any
entries with my keyboard (as described in comment #5 above). I'm sorry I cannot
install Mozilla 1.3a on another Windows machine at the moment.

But it does not work for me by now!
Does really no one have the same problem on Windows XP?

Comment 12

15 years ago
WFM with Mozilla 1.5 on WinXP. 

Reporter, do you still see this problem with the latest nightly (or even 1.5)?
If not, this bug can be closed. Thanks.

Comment 13

14 years ago
Firebird 0.8.0+ (20040130) on XP

Comment 14

14 years ago
Sorry for not responding to this. I think if there's no one out there having the
same problem, it is either fixed now or it was a problem on my machine.

Now, I do not have any windows machine any more around, so I definitely cannot
reproduce this.
Would be best to close this as WORKSFORME. If something related comes up again
on recent versions, I'll complain again. :-)
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.