Closed Bug 1777937 Opened 1 month ago Closed 10 days ago

Thunderbird 102.0 does not automatically recreate ImapMail folder if it is deleted

Categories

(MailNews Core :: Networking: IMAP, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr102+ fixed, thunderbird104 fixed)

RESOLVED FIXED
105 Branch
Tracking Status
thunderbird_esr102 + fixed
thunderbird104 --- fixed

People

(Reporter: simweijie, Assigned: mkmelin)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

Sometimes, it is necessary to delete the ImapMail folder from the Thunderbird profile directory in order to force Thunderbird to grab a new copy of mail from the server. We do this by deleting the ImapMail folder from the local profile directory.

Actual results:

Thunderbird does not re-download the mail but instead errors out with:

The Local Directory path "C:\Users\<username>\AppData\Roaming\Thunderbird\Profiles\<profile directory>\ImapMail\<mailbox name>" is invalid. Please pick a different directory.

Expected results:

Thunderbird should re-fetch the mail automatically from the IMAP server. We have this working on Thunderbird 91. It just stopped working in Thunderbird 102.

Component: Untriaged → Networking: IMAP
Product: Thunderbird → MailNews Core
Blocks: tb102found

I don't think deleting that from the profile is supported. If you must, why not just delete the files inside it?
But I don't see why it would have changed from 91 to 102 either. https://searchfox.org/comm-central/rev/fc083479a94ad7ace9f5abe899dfe63be63b9e3e/mailnews/base/src/nsMailDirProvider.cpp#48

Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: regression
Regressed by: 1724849
Target Milestone: --- → 105 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/e17f4d5f3019
ImapMail should be recreated if missing. r=benc

Status: ASSIGNED → RESOLVED
Closed: 10 days ago
Resolution: --- → FIXED

Comment on attachment 9287479 [details]
Bug 1777937 - ImapMail should be recreated if missing. r=benc

[Approval Request Comment]
Regression caused by (bug #): bug 1724849
User impact if declined: if ImapMail doesn't exist, the account doesn't show anything. This may have some impact in enterprise roaming situations.
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): should be safe

Attachment #9287479 - Flags: approval-comm-esr102?
Attachment #9287479 - Flags: approval-comm-beta?

Comment on attachment 9287479 [details]
Bug 1777937 - ImapMail should be recreated if missing. r=benc

[Triage Comment]
Approved for beta

Attachment #9287479 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9287479 [details]
Bug 1777937 - ImapMail should be recreated if missing. r=benc

[Triage Comment]
Approved for esr102

Attachment #9287479 - Flags: approval-comm-esr102? → approval-comm-esr102+
You need to log in before you can comment on or make changes to this bug.