Problem with the enabled status with the delete button

VERIFIED FIXED in M12

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: mscott, Assigned: hangas)

Tracking

Trunk
x86
Other
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
In the 11/2 release build I started noticing some odd behavior with the
delete button in the 3-pane.

In particular, it appears to be disabled. Although function wise, it isn't.
I can delete messages just fine.

But after a few deletes, the text under the delete icon is a darker color than
other button text. And mousing over the delete button doesn't give me that
light

blue circle that it used to either.

Updated

19 years ago
QA Contact: lchiang → esther
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Depends on: 17847
Target Milestone: M11
(Assignee)

Comment 1

19 years ago
This bug is caused by the commandupdater stuff not firing.  This was broken
between noon 11/1/99 and the morning of 11/2/99.  Bug 17847 is currently assigned
to waterson to fix the commandupdater stuff.

Updated

19 years ago
Blocks: 17976
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
Waterson fixed 17847, so this is working again.

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: FIXED → ---

Comment 3

19 years ago
Using build 1999111017 on win98 and linux and build 1999111111 on Mac this
appears to be broken again.  The only difference is the Delete button displays
as enabled (button text is light blue and mousing over it will encirlce the
button) the first time you select a message in the thread pane.  After you
Delete the message, the button appears as disabled (button text is dark blue and
mousing over it does not encirle the button), but it still works if you click
it again.
May be related to bug 17947 (focus issues) because if you click in the tread
pane after deleting the message to gain focus, the button displays correctly.
Reopening to have Paul determine if this is now a dup of 17947 or dependent on
it.

Comment 4

19 years ago
I think we will have to release note this for M11.
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
Target Milestone: M11 → M12
(Assignee)

Comment 5

19 years ago
Looks like this can be fixed now with saari's focus checkins.  I will look at it
soon.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
Now that this has been fixed through a focus checkin by saari and some style
checkins I made today, I have enabled the normal button behavior here again.  The
delete button will now be enabled only when it can be used and disabled
otherwise.  The disabled state is still not very obvious but that will change
when the opacity bug is fixed.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
Using win build 1999111909m12 and mac build 1999112008 and linux build
1999112008 this is fixed. Verified.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.