Closed Bug 1778043 Opened 1 month ago Closed 7 days ago

TB 102 - After editing contacts from certain CardDAV address books (e.g. Google Contacts), field type labels are lost (e.g. "work", "home", "cell", "fax" etc. for phone numbers/addresses)

Categories

(Thunderbird :: Address Book, defect, P1)

Thunderbird 102

Tracking

(thunderbird_esr102+ affected, thunderbird104? affected)

RESOLVED FIXED
105 Branch
Tracking Status
thunderbird_esr102 + affected
thunderbird104 ? affected

People

(Reporter: wrhenshaw99, Assigned: nicolai)

References

(Blocks 2 open bugs)

Details

(Keywords: dataloss, Whiteboard: [TM:102.1.2])

Attachments

(6 files)

Attached image before edit.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.0.0 Safari/537.36

Steps to reproduce:

Edit a contact in a CALDAV address book with multiple phone numbers
Correct labels are not shown in edit window, all are shown as NONE
Make a change to something other than phone numbers
Save contact
All labels for contact phone numbers are set to NONE

Actual results:

All previous labels for contact phone numbers are removed.

Expected results:

Labels for contact phone numbers should be shown in the edit window and changed on the contact only if modified in the edit window.

Attached image edit window.jpg
Attached image after edit.jpg
Blocks: tb102found

TB103.0b2 on Linux.
I can confirm this behavior. Existing labels for a contact are not visible in Edit mode. Labels in Edit mode are just 'None'.
The address book is for Google Contacts via CardDAV.

Status: UNCONFIRMED → NEW
Component: Untriaged → Address Book
Ever confirmed: true

I didn't notice this before. Labels on addresses are also being lost. Rather than displaying in the edit window as "None", they are just blank.

Assignee: nobody → nicolai
Status: NEW → ASSIGNED

Thanks for reporting the issue. In the underlying data from a another vCard source the vCard types could be set to uppercase. The display of a vCard supports this but not yet the edit of a contact.

(In reply to wrhenshaw99 from comment #4)

I didn't notice this before. Labels on addresses are also being lost. Rather than displaying in the edit window as "None", they are just blank.

This behavior is intentional and the label "None" is no type and displayed as a blank type.

(In reply to Nicolai Kasper from comment #5)

Thanks for reporting the issue. In the underlying data from a another vCard source the vCard types could be set to uppercase. The display of a vCard supports this but not yet the edit of a contact.

My CARDDAV address book is linked to Google. None of the labels are in uppercase in Google. They only display as upper case in TB after adding the CARDDAV address book and syncing.

(In reply to wrhenshaw99 from comment #4)

I didn't notice this before. Labels on addresses are also being lost. Rather than displaying in the edit window as "None", they are just blank.

This behavior is intentional and the label "None" is no type and displayed as a blank type.

I must not have explained it very well. In Google all my contact addresses are labeled as Work or Home. When viewed in TB in the CARDDAV address book the labels all appear as Work or Home. When I edit one of those contacts the labels do not appear in the edit window... they are all blank. Shouldn't the labels that exist on the entry show in the edit window?

Bill

I must not have explained it very well either. Thanks for your clarification!

(In reply to wrhenshaw99 from comment #7)

My CARDDAV address book is linked to Google. None of the labels are in uppercase in Google. They only display as upper case in TB after adding the CARDDAV address book and syncing.

There is a difference in the vCard data and how they are represented in a contact.
Although the labels are shown not in uppercase in your Google Contacts, the underlying vCard data which is not shown to you in a UI is in uppercase when sent from google.

I must not have explained it very well. In Google all my contact addresses are labeled as Work or Home. When viewed in TB in the CARDDAV address book the labels all appear as Work or Home. When I edit one of those contacts the labels do not appear in the edit window... they are all blank. Shouldn't the labels that exist on the entry show in the edit window?

Yes the labels that exist on the entry should be shown in the edit window.

I see, thanks for the clarification.

Bill

Summary: TB 102 - Problem editing CALDAV address book - phone number labels → TB 102 - Problem editing CardDAV address book - phone number labels

Afasics, losing field type labels of users' contacts constitutes dataloss -> P1/S2. We should land this asap.
Geoff (reviewer), could you land this now as Nicolai hasn't been around since your r+?

Thanks to Nicolai for fixing this bug!

Severity: -- → S2
Flags: needinfo?(geoff)
Keywords: dataloss
Priority: -- → P1
Summary: TB 102 - Problem editing CardDAV address book - phone number labels → TB 102 - After editing contacts from certain CardDAV address books (e.g. Google Contacts), field type labels are lost (e.g. "work", "home", "cell", "fax" etc. for phone numbers/addresses)
Flags: needinfo?(geoff)
Target Milestone: --- → 104 Branch

Needs unbitrotting

Flags: needinfo?(nicolai)
Flags: needinfo?(nicolai)
Target Milestone: 104 Branch → 105 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/dc7f84412cbd
Support uppercase types for contact edits. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 7 days ago
Resolution: --- → FIXED

Comment on attachment 9284342 [details]
Bug 1778043 - Support uppercase types for contact edits. r=darktrojan

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: In the edit view types from CardDAV sources with uppercase types are not able to be set or send.
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): Low-Medium. This could lead to further problems of Address Books who only support uppercase types (there are no known for me until now). E.g. google supports only uppercase types but is able to convert lowercase types to uppercase for their usage. This patch is depended on the patch from Bug 1776214.

Attachment #9284342 - Flags: approval-comm-esr102?
Attachment #9284342 - Flags: approval-comm-beta?
Whiteboard: [TM:102.1.2]

Comment on attachment 9284342 [details]
Bug 1778043 - Support uppercase types for contact edits. r=darktrojan

[Triage Comment]
Approved for beta

Attachment #9284342 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.