Closed Bug 1778049 Opened 3 months ago Closed 3 months ago

The website eco99fm.maariv.co.il is blank with ETP set to Strict

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

Firefox 104
Other
Android
defect

Tracking

()

RESOLVED FIXED
104 Branch
Tracking Status
firefox104 --- fixed

People

(Reporter: calin.tanase, Assigned: twisniewski)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files, 1 obsolete file)

Attached image eco99fm Strict ETP..png (obsolete) —

Environment:
Operating system: Android 11
Firefox version: Firefox Nightly Mobile 104.0a1 (GV: 104.0a1-20220630095519)

Preconditions:
ETP set to STRICT
Clean profile

Steps to reproduce:

  1. Go to https://eco99fm.maariv.co.il
  2. Observe the page

Expected Behavior:
The website loads correctly.

Actual Behavior:
The website is blank, contains no content/elements.

Notes:

  1. Screenshot provided
  2. Not reproducible on Chrome
  3. Not reproducible on Desktop
  4. Not reproducible with Standard ETP
  5. The results are the same in Private Window
Attachment #9284085 - Attachment is obsolete: true
Attached image eco99fm.png
Severity: -- → S3

The content is pushed off the page for me in responsive design mode unless I make the window large enough.

That's because on small window sizes (such as on a mobile screen) their page first forces the user to view an ad that is being blocked (they must dismiss the ad before the page resizes to a mobile layout).

Indeed, an error is visible in the console, which reveals that this piece of code is failing, as there are no child nodes for the ad:

     onLoad() {
        const t = this.adRef.nativeElement.children;
        this.showDialog = t.item(0).hasChildNodes(),
        this.showCloseButton = t.item(0).hasChildNodes()
      }

I see that SmartBlock shims are kicking in, so we may be able to adjust those to work with this site.

Ah, this sites passes not an element id, but a slot, to the display function of GPT. I've been wondering how long it would be before I saw this in the wild. This can be easily fixed in the shim, and I've got a patch in the works, but unfortunately the site is also simply broken. Their above code doesn't wait until after they've defined and displayed their ads, and so it will randomly happen that you're left on a page with endless ads you can't escape until you reload (or you'll get a black page until you reload, if the ads are blocked). There's not much I can do about that; I'd be surprised if it somehow doesn't also happen in other browsers.

Assignee: nobody → twisniewski
Status: NEW → ASSIGNED
Pushed by twisniewski@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/11a79b51deeb
update the SmartBlock GPT shim to accept elements and slots as the parameter for display, and return already-defined slot when attempting to re-use the same id in defineSlot; r=ksenia,webcompat-reviewers
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 104 Branch
You need to log in before you can comment on or make changes to this bug.