Closed Bug 1778082 Opened 3 months ago Closed 3 months ago

about:profiles no longer shows the currently running profile

Categories

(Toolkit :: Startup and Profile System, defect)

defect

Tracking

()

VERIFIED FIXED
104 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox-esr102 --- unaffected
firefox102 --- unaffected
firefox103 --- unaffected
firefox104 --- verified

People

(Reporter: mossop, Assigned: mossop)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

In current nightlies on at least macOS and linux going to about:profiles does not show which profile is in use. Additionally nsIToolkitProfileService::currentProfile is null indicating that this is some internal failure. This problem does not occur on beta.

This problem appears to have been caused by https://hg.mozilla.org/integration/autoland/rev/f79083f74800.

The change has broken the way we ensure there is only one instance of the profile service in the process. The old XPCOM factory that was defined used to check whether a singleton instance had already been created and if so return that. The very first instance however is not created via XPCOM.

So on startup we now create the instance that we use to determine the current profile but anything later that attempts to get the profile service via XPCOM ends up getting a second instance that knows nothing about how the application was launched.

Flags: needinfo?(kmaglione+bmo)
Regressed by: 1773770
Assignee: nobody → dtownsend
Flags: needinfo?(kmaglione+bmo)

Set release status flags based on info from the regressing bug 1773770

Pushed by dtownsend@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/21abd775681d
Ensure nsToolkitProfileService is a singleton regardless of how it is accessed. r=kmag
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 104 Branch
QA Whiteboard: [qa-104b-p2]

Hello,
I managed to reproduce this issue on Nightly 104.0a1(build ID: 20220705212856) on Ubuntu 22.04. Verified as fixed on Firefox 104.0(build ID: 20220816115024) and Nightly 105.0a1(build ID: 20220816190318) on Ubuntu 22.04, macOS 12 and Windows 10.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-104b-p2]
You need to log in before you can comment on or make changes to this bug.