Closed Bug 1778160 Opened 3 months ago Closed 2 months ago

Extraneous file extension added with application/x-msdos-program

Categories

(Firefox :: File Handling, defect)

Firefox 102
defect

Tracking

()

RESOLVED DUPLICATE of bug 1772140
Tracking Status
firefox103 --- affected
firefox104 --- affected

People

(Reporter: jscher2000, Unassigned)

References

(Blocks 1 open bug)

Details

Users are reporting unusual file extensions being tagged on to .exe file names during download, if the file was served with

Content-Type: application/x-msdos-program

These are the two I've seen so far:

.bin - https://support.mozilla.org/questions/1381232

.mjr - https://connect.mozilla.org/t5/discussions/downloads-missing-file-type-extension/m-p/9175/highlight/true#M3849

I don't know how to replicate this for testing.

Blocks: 1778322

This is very similar or maybe dupe of Bug 1772140

See Also: → 1772140

Reproduce the issue on Win10 using build 102.0b1 (20220530132252) using the handlers.json from bug 1772140.
Issue still reproduces on Win10 using Beta 103.0b8 (20220712185923) and Nightly 104.0a1 using the handlers.json from bug 1772140.

Flags: needinfo?(jscher2000)
Flags: needinfo?(jscher2000)

I think we probably just dupe this to bug 1772140, there doesn't seem to be much point tracking it separately.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1772140
You need to log in before you can comment on or make changes to this bug.