Ctrl+Enter goes to www.foo.com, but History stores only foo

VERIFIED FIXED in Phoenix0.5

Status

()

Firefox
Location Bar
VERIFIED FIXED
15 years ago
14 years ago

People

(Reporter: djst, Assigned: Blake Ross)

Tracking

unspecified
Phoenix0.5
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
If you enter "foo" and press Ctrl+Enter, you will be taken to the breathtaking
site www.foo.com, but if you enter "fo" and look at the autocomplete list, it
will display "http://foo/".
(Reporter)

Comment 1

15 years ago
Sorry, pressed Submit too soon.

Steps to reproduce:

1. enter "foo" in the address field.
2. press ctrl+enter
3. you'll be taken to www.foo.com.
4. enter "fo" in the address field.

expected results:
http://www.foo.com/ is displayed in the autocomplete list

actual results:
http://foo/ is displayed instead.
OS: Windows XP → All

Comment 2

15 years ago
This could be related to bug 136228 (one which, for over 6 months, has received
no attention at all) - assuming that they both have the same root cause in terms
of certain event processing.

Comment 3

15 years ago
*** Bug 178207 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

15 years ago
Blake just fixed this but seems to have missed marking this bug fixed.

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/browser/base/content&command=DIFF_FRAMESET&file=browser.js&rev1=1.160&rev2=1.161&root=/cvsroot
Assignee: hewitt → blaker
Target Milestone: --- → Phoenix0.5
(Assignee)

Comment 5

15 years ago
Fixed, thanks.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 6

14 years ago
v.
Status: RESOLVED → VERIFIED

Comment 7

14 years ago
*** Bug 178207 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.