Closed Bug 1778383 Opened 1 month ago Closed 1 month ago

French accents appear in another encoding when viewing messages

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 102
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: hugues, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image testtb.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.0.0 Safari/537.36

Steps to reproduce:

I have a french Windows 10, was on Thunderbird x32 until today and upgraded with the .msi installer to x64 v.102 - all went fine and extremly smooth.
Now when opening my mail boxes, I find some e-mails that include french accents that have a weird font and accentslook like Cyrillic.

Actual results:

Nothing between the two installs. I must mention that this happens also on some webpages of Firefox.

Expected results:

an accent like é or è should not display as cyrillic

It sems to happen on "Helvetica" fonts

OK after removing Helvetica font, it works. No accent problem anymore - maybe it's related to how Firefox & Thunderbird manage some fonts.
For some reason my colleague uses "Helvetica Neue LT STD 65" and I did not need to remove the font on her computer, accents work alright.
Hope this helps french users !

Blocks: tb102found

-> WFM per comment 2.

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.