When menu dropped down and left down, draws smaller over itself

VERIFIED WORKSFORME

Status

()

Core
XUL
P4
normal
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: cpratt, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build ID: 1999110208
Platform: All

To reproduce:

- Launch the browser
- Click on the Bookmarks menu to drop it down
- Wait a second or two for the images to load

Result: The menu is not redrawn correctly. It seems to draw over itself a second
time, covering about 60% of the original menu.

Expected result: Ideally of course we wouldn't draw it before we display it, but
if we do, we need to redraw correctly.

Comment 1

19 years ago
I'm not seeing this in today's opt build, win98.  I don't see any images in the
bookmarks menu either.
(Reporter)

Comment 2

19 years ago
I really should check again and make sure this happens on platforms other than
Linux. To see this, you'd ideally do it on Linux running on a slowish machine
(mine's a 166 MHz Pentium I think).

Comment 3

19 years ago
I've got a P166 Linux box too, I'll try it tomorrow.

Updated

19 years ago
Assignee: trudelle → saari
Priority: P3 → P4
Target Milestone: M14

Comment 4

19 years ago
Okay, I see, the images for the submenu triagles.  This happens with other menus
too, but is only cosmetic.  assigning to saari as p4 for m14
Component: XP Toolkit/Widgets → XPMenus
QA Contact: claudius → sairuh
reassigned QA contact to me & updated component. h'm, i didn't see this
behavior with 1999121509 (on winNT); still a problem for other people...? i
checked this by going to the Bookmarks item in the main menubar.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M14 → M15
(Assignee)

Updated

19 years ago
Assignee: saari → pinkerton
Status: ASSIGNED → NEW
(Assignee)

Comment 6

19 years ago
taking popup/menu bugs. I hate my life.
(Assignee)

Comment 7

19 years ago
works for me.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

19 years ago
me too. this worked itself out a while back.
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
BULK MOVE: Changing component from XP Menus to XP Toolkit/Widgets: Menus.  XP 
Menus component will be deleted.
Component: XPMenus → XP Toolkit/Widgets: Menus

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.