Closed Bug 1778907 Opened 2 years ago Closed 2 years ago

Firefox View "tab" feels slower than other tabs because it opens on mouse click release, rather than immediately on mouse click

Categories

(Firefox :: Firefox View, defect, P2)

Firefox 104
All
Unspecified
defect
Points:
2

Tracking

()

VERIFIED FIXED
105 Branch
Tracking Status
firefox104 --- disabled
firefox105 --- verified

People

(Reporter: lolrepeatlol, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fidefe-2022-mr1-firefox-view])

Attachments

(1 file)

One thing I noticed while opening Firefox View and following its progress was that it opens slightly slower than other tabs.

I discovered that this was the case because unlike "real" tabs in Firefox, Firefox View opens when you release your mouse click rather than immediately on click.

For consistency and a good user experience, Firefox View's "tab" should open with the same speed as ordinary Firefox tabs -- immediately on mouse click.

Blocks: firefox-view
Whiteboard: [fidefe-2022-mr1-firefox-view]
Component: General → Firefox View
Severity: -- → S4
Points: --- → 2
Priority: -- → P2
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/382fb4ae0e04
Open Firefox View tab on mousedown. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch

Reproduced the initial issue described in comment 0 using old Nightly from 2022-07-10. Verified that using latest Firefox 106.0b5 across platforms (Windows 10, macOS 11.6 and Ubuntu 21.04) the switch to Firefox View is made once the user clicks on the tab and not when releasing it.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: