Closed Bug 1778969 Opened 5 months ago Closed 5 months ago

Newsgroups: Some messages are not displayed

Categories

(MailNews Core :: Networking: NNTP, defect)

Thunderbird 102
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1778229

People

(Reporter: blueice_haller, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:101.0) Gecko/20100101 Firefox/101.0

Steps to reproduce:

Since the update to Thunderbird 102 (with the changed UI and Address Book) I have the following issue:

  1. Navigate to Newsgroup A

  2. Display Message A.1
    → The Message is displayed (in "Message Pane" area or using double-click in a new tab)

  3. Navigate to Newsgroup B (on the same Newsserver like Newsgroup B

  4. Display Message B.1
    → The Message is not displayed (in "Message Pane" area or using double-click in a new tab)

  5. Display Message B.2
    → The Message is displayed (in "Message Pane" area or using double-click in a new tab)

  6. Navigate to Newsgroup C (on the same Newsserver like Newsgroup A and B

  7. Display Message C.1
    → The Message is not displayed (in "Message Pane" area or using double-click in a new tab)

Left below it shows: "Loading Message..." / "Nachricht laden..."

Actual results:

The Message B.1 is not displayed "Message Pane" area or using double-click in a new tab

Expected results:

The Message B.1 should be displayed in both "Message Pane" area or using double-click in a new tab

In this Profile there is no IMAP/POP3 Account configured, only Newsgroup and SMTP.

2022-07-11_1317_mass-mark-TB102found

Blocks: tb102found

Version History:
2022-07-11: 102.0.1 (64-Bit)
2022-07-06: 102.0 (64-Bit)

When I remember correctly when displaying expired messages it showed an button "Remove all expired Messages" (?).
This is currently not displayed on the oldest messages.
Instead it shows "Loading Messages..." on all messages, even messages that were displayed before displaying expired messages.
The only workaround that I know that works then is close/exit/quit TB and start TB again.

Thanks blueice. We've noted some issues on news.

Component: Untriaged → Networking: NNTP
Product: Thunderbird → MailNews Core
See Also: → 1777439
Summary: Newsgroup some messages are not displayed → Newsgroups: Some messages are not displayed

(In reply to blueice_haller from comment #3)

When I remember correctly when displaying expired messages it showed an button "Remove all expired Messages" (?).
This is currently not displayed on the oldest messages.

If that is your problem, it is covered by bug 1778229.
I just can't tell if it will be fixed in TB102 as well.

With 102.0.1 (64-Bit) the situation got better and the most messages are displayed.

With 102.0.2 (64-Bit) I don't see any difference to 102.0.1 (64-Bit) even anything has been changed in the code ;-) .
For example on one thread which I'm able to read it shows that there is one unread message where is shows "Loading Message..."
which has been sent one minute later than the message I'm able to read.

Version History (when I installed which Version):
2022-07-14: 102.0.2 (64-Bit)
2022-07-11: 102.0.1 (64-Bit)
2022-07-06: 102.0 (64-Bit)

Release Notes
https://www.thunderbird.net/en-US/thunderbird/102.0.2/releasenotes/?uri=/thunderbird/releasenotes/&locale=de&version=102.0.2&channel=release&os=WINNT&buildid=20220708192300

fixed - Offline cache was unusable for NNTP accounts

Today I tried out the Error Console (Ctrl+Shift+J).

When I start TB it shows these Messages (Every time I close and open TB):

  1. 1657870577465 addons.xpi WARN Checking C:\Program Files\Mozilla Thunderbird\distribution\extensions for addons

  2. Warning: This page is in Quirks Mode. Page layout may be impacted. For Standards Mode use “<!DOCTYPE html>”. [Learn More] hiddenWindow.html
    [Learn More] → https://developer.mozilla.org/en-US/docs/Web/HTML/Quirks_Mode_and_Standards_Mode

  3. Trying to load C:\Program Files\Mozilla Thunderbird\libotr.dll OTRLib.jsm:64:11

  4. Successfully loaded OTR library C:\Program Files\Mozilla Thunderbird\libotr.dll OTRLib.jsm:72:13

  5. Successfully loaded OpenPGP library rnp.dll version 0.16+git20220124.f06439f7.MZLA from C:\Program Files\Mozilla Thunderbird\rnp.dll RNPLib.jsm:100:15

  6. Found 0 public keys and 0 secret keys (0 protected, 0 unprotected) RNPLib.jsm:301:15

  7. Warning: services.settings: Failed to load last_modified.json: TypeError: NetworkError when attempting to fetch resource. Utils.jsm:330

When I execute right click and "Copy all Messages" it shows this Error:
TypeError: toolbox is null [Learn More] context-menu.js:341:42
[Learn More] → https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Errors/Unexpected_type

When I try to display the Newsgroup Message which shows only "Loading Message..." it shows no entry in Error Console

When I display one Newsgroup Message which I'm able to display it shows these Messages:

  1. Warning: This page is in Quirks Mode. Page layout may be impacted. For Standards Mode use “<!DOCTYPE html>”. taoo3j$h9s$1@news.###########.de
  2. Error: Error reading message 1 undefined
  3. contentscript: MUA info content-script.js:94:15
  4. MUAstring1 is undefined content-script.js:136
    setContent moz-extension://03a5c4d6-9727-4a7f-a26d-d86473431938/scripts/content-script.js:136
    <anonymous> moz-extension://03a5c4d6-9727-4a7f-a26d-d86473431938/scripts/content-script.js:115
    apply self-hosted:2669
    applySafeWithoutClone resource://gre/modules/ExtensionCommon.jsm:704
    asyncWithoutClone resource://gre/modules/ExtensionCommon.jsm:2607

Can you reproduce in Help | Troubleshoot mode?

(In reply to Magnus Melin [:mkmelin] from comment #9)

Can you reproduce in Help | Troubleshoot mode?

I tried with the same result: Error Console (Ctrl+Shift+J) doesn't show any message when I try to display one Newsgroup Message.
It just shows left bottom "Loading Message...".

I can try the following: https://bugzilla.mozilla.org/show_bug.cgi?id=1777439#c24 ...

(In reply to Ping Chen (:rnons) from comment #24)

(In reply to Marc Auslander from comment #22)

I'm on 102.0.1 which "fixed" my nntp problem. But it's suddenly reappeared! Again, just blank page when I open a message. turning off jsmodule fixes it so its not a server issue. How can I help?

Please share some debug logs like comment 2 and comment 3. Go to Config Editor, set mailnews.nntp.loglevel to All, thanks.

... and compare my Logs with that from Marc Auslander.

When I display a message which can't be displayed and that has not expired it shows the following Messages in the Error Console:

  1. Debug: mailnews.nntp: C: ARTICLE 361992 NntpClient.jsm:211:20
  2. Debug: mailnews.nntp: S: 423 No such article number 361992 NntpClient.jsm:142:18

When I start TB and open the Error Console (Ctrl+Shift+J) it shows these Messages (Every time I close and open TB):

  1. Info: 1658143646313 addons.xpi WARN Checking C:\Program Files\Mozilla Thunderbird\distribution\extensions for addons

  2. Warning: This page is in Quirks Mode. Page layout may be impacted. For Standards Mode use “<!DOCTYPE html>”. hiddenWindow.html
    [Learn More] → https://developer.mozilla.org/en-US/docs/Web/HTML/Quirks_Mode_and_Standards_Mode

  3. Debug: Successfully loaded OpenPGP library rnp.dll version 0.16+git20220124.f06439f7.MZLA from C:\Program Files\Mozilla Thunderbird\rnp.dll RNPLib.jsm:100:15

  4. Debug: Trying to load C:\Program Files\Mozilla Thunderbird\libotr.dll OTRLib.jsm:64:11

  5. Debug: Successfully loaded OTR library C:\Program Files\Mozilla Thunderbird\libotr.dll OTRLib.jsm:72:13

  6. Debug: Found 0 public keys and 0 secret keys (0 protected, 0 unprotected) RNPLib.jsm:301:15

  7. Warning: services.settings: Failed to load last_modified.json: TypeError: NetworkError when attempting to fetch resource. Utils.jsm:330

  8. Debug: mailnews.nntp: Connecting to snews://news.###########.####:563 NntpClient.jsm:103:20

  9. Debug: mailnews.nntp: Connected NntpClient.jsm:121:18

  10. Warning: Layout was forced before the page was fully loaded. If stylesheets are not yet loaded this may cause a flash of unstyled content. aboutconfig.js:470:9

  11. Debug: mailnews.nntp: S: 200 news.###########.de InterNetNews NNRP server INN 2.6.1 ready (no posting) NntpClient.jsm:142:18

  12. Debug: mailnews.nntp: C: MODE READER NntpClient.jsm:211:20

  13. Debug: mailnews.nntp: S: 200 news.###########.de InterNetNews NNRP server INN 2.6.1 ready (no posting) NntpClient.jsm:142:18

  14. Debug: mailnews.nntp: C: Logging suppressed (it probably contained auth information) NntpClient.jsm:205:20

  15. Debug: mailnews.nntp: S: 381 Enter password NntpClient.jsm:142:18

  16. Debug: mailnews.nntp: C: Logging suppressed (it probably contained auth information) NntpClient.jsm:205:20

  17. Warning: Relative positioning of table rows and row groups is now supported. This site may need to be updated because it may depend on this feature having no effect. preferences.js:268:2

  18. Debug: mailnews.nntp: S: 281 Authentication succeeded NntpClient.jsm:142:18

  19. Debug: mailnews.nntp: C: GROUP ########### NntpClient.jsm:211:20

  20. Debug: mailnews.nntp: S: 211 3402 358705 362112 ########### NntpClient.jsm:142:18

  21. Debug: mailnews.nntp: Done with status=0 NntpClient.jsm:750:18

When I keep the Error Console (Ctrl+Shift+J) open and close and open TB it shows many Exceptions:

When I close TB:

  1. TypeError: window is undefined window-global.js:1358:7
    _changeTopLevelDocument resource://devtools/server/actors/targets/window-global.js:1358
    _onDocShellDestroy resource://devtools/server/actors/targets/window-global.js:979
    observe resource://devtools/server/actors/targets/parent-process.js:140

  2. Debug: mailnews.nntp: C: QUIT NntpClient.jsm:211:20

  3. [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDocShell.domWindow]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: resource://devtools/server/actors/targets/window-global.js :: get window :: line 422" data: no] window-global.js:422:5
    get window resource://devtools/server/actors/targets/window-global.js:422
    _getWindowForBrowserConsole resource://devtools/server/actors/webconsole.js:269
    get global resource://devtools/server/actors/webconsole.js:247
    makeDebuggeeValue resource://devtools/server/actors/webconsole.js:470
    arguments resource://devtools/server/actors/webconsole.js:2058
    map self-hosted:180
    prepareConsoleMessageForRemote resource://devtools/server/actors/webconsole.js:2057
    onConsoleAPICall resource://devtools/server/actors/webconsole.js:1793
    onConsoleAPICall self-hosted:1115
    onConsoleAPILogEvent resource://devtools/server/actors/webconsole/listeners/console-api.js:115
    onConsoleAPILogEvent self-hosted:1115
    CS_recordEvent resource://gre/modules/ConsoleAPIStorage.jsm:174
    _onClose resource:///modules/NntpClient.jsm:171

When I keep the Error Console (Ctrl+Shift+J) open and close and open TB it shows many Exceptions:

When I start TB: see attachment: error console when I start TB.txt

I tried to right click on one message and "Save all Messages to file" but it shows no "Save as ..." prompt.

I tried to right click on one message and "Copy all Messages" but it shows the previous content in the clipboard.

(In reply to blueice_haller from comment #12)

When I display a message which can't be displayed and that has not expired it shows the following Messages in the Error Console:

  1. Debug: mailnews.nntp: C: ARTICLE 361992 NntpClient.jsm:211:20
  2. Debug: mailnews.nntp: S: 423 No such article number 361992 NntpClient.jsm:142:18

This looks like bug 1778229

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE

I'm currently on 102.0.3 (64-bit).
In bug 1778229 it shows: thunderbird_esr102 --- fixed

What do I need to do to install the Version which contains the fix?

Do you mean I need to manually install it from https://ftp.mozilla.org/pub/firefox/releases/102.1.0esr/ ?

No, that's firefox. 102.1 will be out soon (today I think).

Today I installed 102.1.1 (64-bit) via Help → About Thunderbird.

The good is that it shows such a message when I try to open an expired article:

Article not found

The newsgroup server reports that it can't find the article.

• Newsgroup server responded: No such article number 357708
• Perhaps the article has expired?
• Try searching for article: <t1cljo$2aq$1@news.###########.de> (357708)

Unfortunately it doesn't show an button to remove all expired articles like in a previous Version.
Do you know how can I request the implementation of the button?

(In reply to blueice_haller from comment #22)

Unfortunately it doesn't show an button to remove all expired articles like in a previous Version.

This is a known issue:
Bug 1782365 - On the "Article not found" error page the "Remove All Expired Articles" button is still missing

You need to log in before you can comment on or make changes to this bug.