browser crash when loading new URL

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
--
critical
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Salve J. Nilsen, Assigned: rubydoo123)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed with Flash 6], URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021028
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021028

Browser crashes with the following error:

Error: Object "drawingArea" does not have windowed ancestor

I don't know which part of the HTML (or something else) triggers the error, but
I'll attach the web page...

Reproducible: Always

Steps to Reproduce:
1. Start mozilla
2. Goto <URL:
http://www.aftenposten.no/nyheter/uriks/article.jhtml?articleID=428594 >
3. Watch mozilla burn

Comment 1

16 years ago
WFM 2002102608 / Win98

Possibly Linux only.
(Reporter)

Comment 2

16 years ago
Created attachment 104863 [details]
Web page that crashes

I downloaded the full page (w/images) Opera, and tried viewing it locally with
mozilla, and was successful (no crash).

I've tested this with 1.2a and 1.1
(Reporter)

Comment 3

16 years ago
Interesting note: viewing the attachment doesn't crash mozilla, but following
the URL does.

Perhaps one of the components using a "local" URL make mozilla crash?
Additionally the HTML is pretty b0rken. :-(

Updated

16 years ago
Keywords: crash

Comment 4

16 years ago
wfm using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020918
although after two minutes the status bar down below says it is still
transferring data from the site but nothing else is loading.  It looks the same
as the attachment.  I also run redhat 7.1 w/many updates.  flash 5.0 and java
1.3.1_01

Comment 5

16 years ago
Created attachment 105064 [details]
Javascript to load flash content

The page contains some javascript which checks the browser ID string, then
either loads some GIF ads, or else loads some javascript (attachment) that in
turn loads some flash content. I suspect the "drawingArea" error message is
actually from the flash plugin, though the string doesn't seem to be in my copy
of the plugin (5.0 r50).

The page doesn't cause a crash for me, but when I right-click in one of the
flash content areas, the menu says (something like) "Flash content not loaded".
Maybe the flash server is down right now.

Salve, what version of the flash plugin are you using? If it's something old,
could you try upgrading?
(Reporter)

Comment 6

16 years ago
I'm using libflashplayer.so 5.0 r47 (15 February 2001, according to the README file)

I'll try to upgrade.
(Reporter)

Comment 7

16 years ago
Upgraded to version 5.0 r51 (from 9 September 2002, according to the README.)

Went then to http://www.flash.com/ where the browser again crashed with the
following error:

Error: Object "drawingArea" does not have windowed ancestor

Using "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021104"

IMPORTANT: I'm using the xft experimental builds from
http://ftp.mozilla.org/pub/mozilla/nightly/experimental/xft/2002-11-04-08/ (!!)

Sorry I forgot to tell.. :-(

(maybe experimental builds should have it's own Build Identifier?)
(Reporter)

Comment 8

16 years ago
Plugins I'm using:

libNPSVG3.so (Adobe SVG Viewer)
libjavaplugin_oji.so (Java(TM) Plug-in 1.3.1-b24)
libflashplayer.so (Shockwave Flash 5.0 r51)


(Reporter)

Comment 9

16 years ago
Have tested a little more with "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b)
Gecko/20021104" (Experimental XFT RPM) and "Mozilla/5.0 (X11; U; Linux i686;
en-US; rv:1.1) Gecko/20020827" (stable RPM.)


Neither versions crash if the flash plugins aren't loaded (i.e. rename the .so
file to .so.bak)

Both versions crash when viewing the URL. This is true with both r47 and r51 of
the flash plugin.

Hope this helps!

Comment 10

16 years ago
Do you still crash when removing libNPSVG3.so (Adobe SVG Viewer) ?
If so, this is dupe of bug 133567.
Otherwise, try upgrading to JRE 1.4.1 and Flash 6.0r60.
Assignee: asa → beppe
Component: Browser-General → Plug-ins
Keywords: stackwanted
QA Contact: asa → shrir
(Reporter)

Comment 11

16 years ago
Removing the Adobe SVG viewer (and enabling flash again) didn't stop the crashing.
I've tested with JRE 1.3 and 1.4.1, and none of them made the browser crash less.

Where do I get Flash 6.0r60? (I'm running linux, and Macromedia seems only to
have released flash 5.0 to the public.)

I've noticed there's a beta
(<http://radio.weblogs.com/0106797/2002/10/18.html#a313>) but I'm not quite
comforable registering for that...

How do I create a stack dump? (cf. the "stackwanted" keyword)

Comment 12

16 years ago
Flash 6:
http://www.macromedia.com/software/flashplayer/special/beta/ (more than
recommended, it fixes at least 3 Linux topcrasher bugs)

Stacktrace: either use GDB by starting mozilla with "mozilla --debug" 
http://www.mozilla.org/unix/debugging-faq.html

or download a Talkback-enabled build and send Talkback ID for this crash
"mozilla/bin/components/talkback/talkback"
http://ftp.mozilla.org/pub/mozilla/nightly/latest
(Reporter)

Comment 13

16 years ago
Installed 6.0r60. Flash doesn't crash the browser anymore! :-)

I'll see if I can find some time later to give you a stack trace. Thanks for the
help!

(BTW, this bug should probably not be closed yet, since there's obviously
something wrong with how Mozilla handles misbehaving plugins.)

Comment 14

16 years ago
do you run Mozilla on a remote display (see bug 58937) ?
(Reporter)

Comment 15

16 years ago
I'm running mozilla on a local display. I coould attach the output of
xdpyinfo(1) if that would be useful...

Comment 16

16 years ago
Not sure we can leave this open unless you provide a stack trace.
This is then covered somewhere else: bug 156493.

Ed, maybe you can enlighten on why this is fixed with Flash 6, otherwise, sorry
and I'll remove you from the list.
Whiteboard: [fixed with Flash 6]

Comment 17

16 years ago
I'm not able to reproduce the crash, I got an "Internal Server Error" on the URL.  Without a stack trace I wouldn't hazard a guess about the cause or what fixes it in Flash 6.  At this point I really wouldn't waste much time on bugs involving the Flash 5 player,  the Flash 6 player should generally be much more stable. 

Comment 18

16 years ago
Marking WFM as per above comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.