All users were logged out of Bugzilla on October 13th, 2018

Status

()

VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: king_george_iii, Assigned: colin)

Tracking

({qawanted})

Trunk
DEC
OpenVMS
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
No proxy server used for HTTP, ran Newsreader, then tried to access a web site -
crash. First time that happened. Can't reproduce the situation. Hopefully the
traceback helps you to locate the bug. Good luck!

%SYSTEM-F-ACCVIO, access violation, reason mask=00, virtual
address=0000000000000000, PC=000000007BC22FB0, PS=0000001B
%TRACE-F-TRACEBACK, symbolic stack dump follows
  image    module    routine             line      rel PC           abs PC
                                            0 000000007BC22FB0 000000007BC22FB0
                                            0 FFFFFFFF80DDD8B0 FFFFFFFF80DDD8B0
 LIBNSPR4  PTIO  pt_Close               79428 000000000000105C 0000000001C6AB4C
 MOZILLA-BIN  NSSOCKETTRANSPORT  CloseConnection
                                       143632 0000000000003340 00000000007DE0A0
 MOZILLA-BIN  NSSOCKETTRANSPORT  Process
                                       142851 0000000000001B00 00000000007DC860
 MOZILLA-BIN  NSSOCKETTRANSPORTSERVICE  Run
                                       123510 0000000000001C68 00000000007CD678
 LIBXPCOM  NSTHREAD  Main               23120 0000000000000180 0000000001F094F0
 LIBNSPR4  PTTHREAD  _pt_root           77012 000000000000014C 0000000001C6FE4C
 PTHREAD$RTL                                0 0000000000037894 000000007BC2D894
 PTHREAD$RTL                                0 0000000000026AC8 000000007BC1CAC8
                                            0 0000000000000000 0000000000000000
 PTHREAD$RTL                                                 ?                ?
                                            0 FFFFFFFF802613F4 FFFFFFFF802613F4
%CMA-F-EXIT_THREAD, current thread has been requested to exit

"has been requested to exit" - hey, I like that !
-> Networking
Assignee: asa → new-network-bugs
Component: Browser-General → Networking
QA Contact: asa → benc
(Assignee)

Comment 2

16 years ago
Interesting. Another networking problem from the same reporter. Bug 176364 is
also a networking problem. It would seem that there's something "different"
about the reporter's network environment. The question is what.

Updated

16 years ago
Keywords: qawanted
(Reporter)

Comment 3

16 years ago
First, removing MOZILLA and reinstalling the product did not fix the
problem. I verified by hand that the entire product was really removed.
Thank you for the OpenVMS PRODUCT installation kit, good job!

I was able to reproduce a crash with almost 100% probability by only
changing the user's BYTLM quota (SYSUAF) to 262144. One web site that
currently triggers the crash is http://www.ebay.com/ . Please try to
reproduce the crash. If you cannot reproduce the crash with a few attempts
(set BYTLM=262144, login new process after updating SYSUAF), then let me
know and I will check the SYSGEN parameters, too.

Hopefully this will also help us to understand the GENERIC_POLL business
later. It seems to me that somewhere something goes wrong (e.g.
insufficient resources), but some routine of the unix jacket stuff ignores
an OpenVMS error status (not that I have ever seen ANY useful OpenVMS error
message from these routines).
(Assignee)

Comment 4

16 years ago
My main test account which I use for most of my Mozilla testing has a BYTLM of
200000 and I don't see this problem. Ever! Here's all my quota values:

Maxjobs:         0  Fillm:       300  Bytlm:       200000
Maxacctjobs:     0  Shrfillm:      0  Pbytlm:           0
Maxdetach:       0  BIOlm:       500  JTquota:       4096
Prclm:           8  DIOlm:       500  WSdef:         4000
Prio:            4  ASTlm:      1000  WSquo:        16000
Queprio:         4  TQElm:       200  WSextent:    150000
CPU:        (none)  Enqlm:      2000  Pgflquo:     800000

Can you post yours for reference? Then we'll move onto SYSGEN parameters if need be.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

16 years ago
Maxjobs:         0  Fillm:     10000  Bytlm:       262144
Maxacctjobs:     0  Shrfillm:      0  Pbytlm:           0
Maxdetach:       0  BIOlm:      4096  JTquota:       4096
Prclm:           0  DIOlm:     16384  WSdef:         2000
Prio:            4  ASTlm:      4096  WSquo:       262144
Queprio:         0  TQElm:       128  WSextent:    524288
CPU:        (none)  Enqlm:     10000  Pgflquo:    2752512
(Assignee)

Comment 6

16 years ago
You seem to have bumped up most of your quotas quite a bit except for TQELM.
Could you try increasing that to, say, 500, just to see if it makes any
difference. Also, I'd really like you to try the new image discussed in bug 176364.

Comment 7

16 years ago
-> colin
Assignee: new-network-bugs → colin
(Assignee)

Comment 8

16 years ago
Please report back with results from increasing TQELM and the new image
discussed in bug 176364. Thanks.

Status: NEW → ASSIGNED
(Assignee)

Comment 9

16 years ago
Closing due to lack of response. Reporter, if you wish to provide the
information request in comment 8, feel free to re-open this bug report and we'll
keep working on this.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 10

15 years ago
V, per Colin.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.