Closed Bug 1779260 Opened 1 month ago Closed 1 month ago

Edit mailing list dialog falls apart and becomes unusable with large font size

Categories

(Thunderbird :: Address Book, defect, P2)

Thunderbird 102

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1777622

People

(Reporter: thomas8, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: useless-UI)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1773295 +++

An unfortunate encounter with a zombie dialog from the past...

STR

  1. In main mail space, hit View > Font Size > Increase Font Size about 5 times (wear your seatbelt!)
  2. Open Address book
  3. Create New List from toolbar button (mouse-only, tough luck for keyboarders)
  4. Try to fill the list with 10 email addresses

Actual result (see screenshot)

  • dialog shows only 6 rows, and not resizable (Bug 1773295)
  • dialog falls apart
    • input fields cut off on right side
    • OK and Cancel button gone
  • dialog becomes unusable
    • you cannot see what you're typing at the end of long addresses
    • you cannot enter more than 6 addresses because scroll bar won't show, and current input field isn't scrolled into view

Expected result

  • Fix this in whichever way, any bandaid fix will be fine - imho we should not wait for the real fix here. Even with regular font size, this dialog has become way too painful due to Bug 1773295. Mailing lists are important for everyday scenarios, also for the enterprise.

^^ comment 0, and Bug 1773295 - can we bandaid-fix this somehow?

Flags: needinfo?(alessandro)
Version: Thunderbird 91 → Thunderbird 102
Blocks: tb102found
Severity: -- → S3
Priority: -- → P2

Thomas, please check Daily or the upcoming 103.b5. Bug 1777622 should have fixed the big font size issue.

(In reply to Richard Marti (:Paenglab) from comment #2)

Thomas, please check Daily or the upcoming 103.b5. Bug 1777622 should have fixed the big font size issue.

ggggrrr, true.

Would you be able to fix the remaining nit (apart from Bug 1773295), namely that for long addresses, the last character entered will be squeezed at the right side of the input, and the cursor at line end will no longer be visible? Needs some right-inside padding in the input...

Flags: needinfo?(richard.marti)

(In reply to Thomas D. (:thomas8) from comment #3)

Would you be able to fix the remaining nit (apart from Bug 1773295), namely that for long addresses, the last character entered will be squeezed at the right side of the input, and the cursor at line end will no longer be visible? Needs some right-inside padding in the input...

Moved the remainder to Bug 1779317 for a clean start.

Status: NEW → RESOLVED
Closed: 1 month ago
Flags: needinfo?(richard.marti)
Flags: needinfo?(alessandro)
Resolution: --- → DUPLICATE
Duplicate of bug: 1777622
You need to log in before you can comment on or make changes to this bug.