Closed Bug 1779284 Opened 5 months ago Closed 4 months ago

Fix duplicated call to thread actor method and avoid duplicated target front list in commands.js

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(firefox105 fixed)

RESOLVED FIXED
105 Branch
Tracking Status
firefox105 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

Details

Attachments

(1 file)

We store a duplicated list of target fronts in commands.js.
This duplicates the list already maintained in TargetCommand:
https://searchfox.org/mozilla-central/rev/9ad01b5eae48436e3bdb8df01be3973e683d5242/devtools/client/debugger/src/client/firefox/commands.js#388-398

This is even more confusing as the "current target" is using the TargetCommand's one:
https://searchfox.org/mozilla-central/rev/9ad01b5eae48436e3bdb8df01be3973e683d5242/devtools/client/debugger/src/client/firefox/commands.js#23-25

On top of this, this code is currently buggy and leads to call some thread actor methods twice for the top level target:
https://searchfox.org/mozilla-central/rev/9ad01b5eae48436e3bdb8df01be3973e683d5242/devtools/client/debugger/src/client/firefox/commands.js#99

Instead we can fully rely on TargetCommand.

This fixes duplicated calls made to top level thread actor.
This was only happening with toolbox not using the Watcher Actor.
i.e. the non-multiprocess Browser Toolbox, Browser Content Toolbox and may be worker toolboxes from about:debugging.

The severity field is not set for this bug.
:bomsy, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(hmanilla)
Severity: -- → S3
Flags: needinfo?(hmanilla)
Priority: -- → P3
Assignee: nobody → poirot.alex
Status: NEW → ASSIGNED
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7fbc69cd1c9f
[devtools] Stop maintaining a duplicate of the target list in the debugger frontend. r=bomsy
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch
You need to log in before you can comment on or make changes to this bug.