Closed Bug 1779384 Opened 1 year ago Closed 1 year ago

Persist collapsed state of tab pickup / recently closed tabs sections across Firefox view reloads/restarts

Categories

(Firefox :: Firefox View, enhancement, P2)

Desktop
All
enhancement

Tracking

()

VERIFIED FIXED
106 Branch
Tracking Status
firefox104 --- disabled
firefox105 --- disabled
firefox106 --- verified

People

(Reporter: Gijs, Assigned: kcochrane)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fidefe-2022-mr1-firefox-view])

Attachments

(1 file)

The discussion in bug 1779160 highlighted that Firefox should remember which Firefox view sections were collapsed / uncollapsed across loads of Firefox view, so that if you refresh the page or restart Firefox, sections don't un-collapse unnecessarily.

Component: General → Firefox View
Severity: -- → S3
Priority: -- → P2

Note that we want to ignore a persisted "collapsed" value for Tab Pickup when the user is in the setup flow - needing to sign in and pair a device before synced tabs can be shown.

Assignee: nobody → jhirsch
Status: NEW → ASSIGNED
Assignee: jhirsch → kcochrane
Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dd71b6e79551
Persist collapsed state of Firefox View lists r=sfoster

Backed out changeset dd71b6e79551 (bug 1779384) for causing browser-chrome failures in browser/components/firefoxview/tests/browser/browser_recently_closed_tabs.js

Backout link: https://hg.mozilla.org/integration/autoland/rev/8a6bf70c0f58737929a9a2bdee8d71ff45de68c5

Push with failures

Failure log

INFO - TEST-UNEXPECTED-FAIL | browser/components/firefoxview/tests/browser/browser_recently_closed_tabs.js | The first link is focused - 
[task 2022-09-14T01:49:46.916Z] 01:49:46     INFO - Stack trace:
[task 2022-09-14T01:49:46.917Z] 01:49:46     INFO - chrome://mochikit/content/browser-test.js:test_ok:1440
[task 2022-09-14T01:49:46.917Z] 01:49:46     INFO - chrome://mochitests/content/browser/browser/components/firefoxview/tests/browser/browser_recently_closed_tabs.js:test_arrow_keys/<:383
[task 2022-09-14T01:49:46.918Z] 01:49:46     INFO - resource://testing-common/BrowserTestUtils.jsm:withNewTab:151
[task 2022-09-14T01:49:46.919Z] 01:49:46     INFO - Arrow down
[task 2022-09-14T01:49:46.919Z] 01:49:46     INFO - Not taking screenshot here: see the one that was previously logged
Flags: needinfo?(kcochrane)
Blocks: 1790714

Just submitted a fix for browser_recently_closed_tabs.js for Sam to review.

Flags: needinfo?(kcochrane)
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 106 Branch

Since nightly and release are affected, beta will likely be affected too.
For more information, please visit auto_nag documentation.

Verified using latest Firefox 106.0b2 across platforms (macOS 11, Windows 10 and Ubuntu 20.04) the state of 'Recently closed' is always persisted after restart, crash, quit. Tab pickup state is also persisted if logged in to FxA, but is always expanded (after restart, crash, quit/reopen) when not logged in to FxA due to 'Switch seamlessly between devices' panel.

Status: RESOLVED → VERIFIED

Comment on attachment 9293591 [details]
Bug 1779384 - Persist collapsed state of Firefox View lists r?sfoster

Beta/Release Uplift Approval Request

  • User impact if declined: Firefox won't remember which Firefox view sections were collapsed / uncollapsed across loads of Firefox view
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Only touches a few Fx View files and adds some new tests to cover the updates
  • String changes made/needed:
  • Is Android affected?: No
Attachment #9293591 - Flags: approval-mozilla-beta?

Comment on attachment 9293591 [details]
Bug 1779384 - Persist collapsed state of Firefox View lists r?sfoster

This landed during the 106 nightly cycle so it doesn't need uplift in 106 beta.

Attachment #9293591 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
You need to log in before you can comment on or make changes to this bug.