Closed Bug 1779513 Opened 3 months ago Closed 3 months ago

Add profiling log for chunk manager updates

Categories

(Core :: Gecko Profiler, task, P3)

task

Tracking

()

RESOLVED FIXED
104 Branch
Tracking Status
firefox104 --- fixed

People

(Reporter: mozbugz, Assigned: mozbugz)

References

Details

Attachments

(1 file)

Bug 1777431 hints at an issue related to the possibly too-eager deletion of old chunks in the parent process.
But it's quite difficult (for me) to reproduce, so it would be helpful to capture what's happening with all the chunks.
And I think it could also give some useful information for future analysis, like the rate at which chunks get filled, etc.

This log goes into profile.profilingLog[<parent pid>].bufferGlobalController.updates, an array of data arrays.
See the related updatesSchema for what's in those data arrays.

Note: There are no direct tests, as this is intended for advanced human users,
and the format is not guaranteed to stay stable.

Pushed by gsquelart@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/daeb0422d6a1
Log chunk updates&deletions in the ProfileBufferGlobalController - r=florian
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 104 Branch
You need to log in before you can comment on or make changes to this bug.