Browser-specific printing options (e.g., backgrounds, headers) aren't available using Fizzilla

RESOLVED DUPLICATE of bug 188508

Status

()

Core
Printing: Output
P1
major
RESOLVED DUPLICATE of bug 188508
15 years ago
15 years ago

People

(Reporter: Mark Mentovai, Assigned: dcone (gone))

Tracking

({pp})

Trunk
Future
PowerPC
Mac OS X
Points:
---
Bug Flags:
blocking1.3 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021016

In the example page at
http://www.mentovai.com/tmp/mozilla-bug-200211011745.html, a variety of
background colors are set using the bgcolor attribute and CSS.  When attempting
to print this page on Mac OS X, using Mozilla 1.2b-2002101612 and Chimera
0.5-2002102604, the background don't print.  No option to print the background
is ever presented anywhere.  This applies to the backgrounds set for the page
<BODY> and tables.

However, the background color set for a <P> element is printed.  This appears
inconsistent: some backgrounds are printed, and others are not.  I can see that
printing backgrounds has had a buggy history in Mozilla, but I can't tell if
this ought to be filed as a separate bug or not.  (Someone using another
platform, turn off whatever "background printing" option Mozilla is supposed to
offer and try printing this page, does the last <P> get printed with a
background color?  If so, that would seem like a seperate bug to me.  If not,
then it's probably part of the same Mac background-printing bug I'm reporting.)

Reproducible: Always

Steps to Reproduce:
Go to http://www.mentovai.com/tmp/mozilla-bug-200211011745.html and print it. 
Optionally search as exhaustively as possible for a "print backgrounds" option
within Mozilla.  I have, and no such option has turned up yet.
Actual Results:  
Backgrounds don't print.

Expected Results:  
Print backgrounds.

(Anyone want to comment on why backgrounds aren't printed by default?  It seems
to me that if no option is to be offerred, Mozilla should just print the
background, and if an option is offerred, the default should be to print them.)

This bug is present in both Mozilla and Chimera.
Because most sites use backgrounds that would not print well (black, eg).

There is no checkbox in "Page Setup" for this in the mac build? (that's where it
is in the Linux build, but we may be using the natiev Mac dialogs...)
(Reporter)

Comment 2

15 years ago
No, no checkboxes of the sort.  The standard Mac OS X page setup boxes are in use.  
There's a "Browser Printing Extensions" selection in the regular Print dialog, provided by 
Mozilla.  It only offers "Print Selection," a few disabled radio buttons that I can't seem to 
figure out what to do with, and "Shrink To Fit Page Width" options.  Nothing about 
backgrounds.

As for the defaults: when a page uses a dark background (like black) doesn't it usually 
also have a light text color (like white)?  Without testing anything, it would seem like a 
page of white-on-black text (on screen) would, by default, print blank sheets.

Mark
we darken the text in that situation... The goal is not to print completely
black pages, which is something the user almost never wants.

Confirming bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: pp
-> dcone
Assignee: rods → dcone
Priority: -- → P1
Target Milestone: --- → Future
*** Bug 184715 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 6

15 years ago
Related to bug 186401?

Mark

Comment 7

15 years ago
*** Bug 184837 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
Using FizzillaMach/2003021203, there is no longer a "Browser Printing
Extensions"  item in the Print dialog menu.

Updated

15 years ago
Summary: Backgrounds never print on Mac, there is no option to print them → Browser-specific printing options (e.g., backgrounds, headers) aren't available using Fizzilla

Comment 9

15 years ago
*** Bug 193046 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Flags: blocking1.3?

Updated

15 years ago
Flags: blocking1.3? → blocking1.3-
(Reporter)

Comment 10

15 years ago
duplicated in the future

*** This bug has been marked as a duplicate of 188508 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.