Closed Bug 17799 Opened 21 years ago Closed 20 years ago

Window size not remembered on Linux

Categories

(Core :: XUL, defect, P4)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 14513

People

(Reporter: dbaron, Assigned: pavlov)

References

Details

(Keywords: platform-parity)

DESCRIPTION:  The window position should be remembered from the previous time
you ran apprunner, rather than always starting up at 6??x4??.  This adds about 5
seconds to my startup time, since the current size is quite small.  Since this
now works on Windows 95, I'm filing this as a platform parity bug.

STEPS TO REPRODUCE:
 1 start apprunner
 2 change the window size
 3 exit
 4 start it again
 5 open a new window (File | New Navigator Window)

ACTUAL RESULTS:
 every new window created is 6??x4??

EXPECTED RESULTS:
 after 4, the first window should be the same size as after 2
 after 5, the new window should be the same size as after 2

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-10-30-08-M11

WORKS CORRECTLY ON:
 * Windows, apprunner, 1999-10-30-08-M11 (I didn't test step 5, and I don't want
to reboot just to test it.  Step 4 works.)
Assignee: trudelle → danm
Priority: P3 → P4
Target Milestone: M14
reassigning to danm as p4 for m14
*** Bug 19204 has been marked as a duplicate of this bug. ***
Mozilla always starts on the first virtual console of Photon. It needs to
start on the current virtual console. Where do I hack in and chage the
starting position of Mozilla?
Depends on: 14513
Summary: [PP] Window position not remembered on Linux → [PP] Window size not remembered on Linux
The underlying reason for this is that the window size is being fetched and stored
incorrectly. Marking dependent on 14513.
Blocks: 13208
Keywords: pp
Moving to M15: same milestone as parent bug 14513.
Target Milestone: M14 → M15
Summary: [PP] Window size not remembered on Linux → Window size not remembered on Linux
Nominating for beta1.  IMO, this is a basic UI issue.
Keywords: beta1
reassigning to me
Assignee: danm → pavlov
fix checked in.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
how is this not a dupe of bug 14513 ? they may have started out differently but they are the same now. Rather than going back 
and forth btw both (bug 14513 was just reopened) I'm just going to dupe this one.
REOPENING to dupe
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
duping


*** This bug has been marked as a duplicate of 14513 ***
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
VERIFIED Dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.