Restore access to Sidebar from Mail/News, Compose and Addressbook

NEW
Unassigned

Status

defect
--
major
17 years ago
4 years ago

People

(Reporter: bugs+mozilla, Unassigned)

Tracking

(Blocks 4 bugs)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments, 1 obsolete attachment)

10.90 KB, patch
standard8
: review+
Bienvenu
: superreview+
Details | Diff | Splinter Review
8.88 KB, patch
exalm7659
: feedback?
neil
philip.chee
: feedback?
mnyromyr
Details | Diff | Splinter Review
9.06 KB, patch
exalm7659
: feedback?
neil
philip.chee
: feedback?
mnyromyr
Details | Diff | Splinter Review
3.30 KB, patch
exalm7659
: feedback?
neil
philip.chee
: feedback?
mnyromyr
Details | Diff | Splinter Review
3.28 KB, patch
exalm7659
: feedback?
neil
philip.chee
: feedback?
mnyromyr
Details | Diff | Splinter Review
2.00 KB, patch
exalm7659
: feedback?
neil
philip.chee
: feedback?
mnyromyr
Details | Diff | Splinter Review
81.40 KB, image/png
Details
Reporter

Description

17 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021031
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021031

I used to install the RedHat 7.x RPM versions of Mozilla, but because they are
not released for a while, I started to use the nightly builds. I noticed that
the nightly builds doesn't have sidebar on MailNews and Message Composition
windows. They are not displayed, there is no slider and there is no option to
show it under View->Show/Hide. The F9 key also doesn't work.

Tested on 2 machines with Linux RedHat 7.2 installed.

The Sidebar of Navigator and Composer windows are displayed correctely.

Reproducible: Always

Steps to Reproduce:
Detailed above.

Actual Results:  
No sidebar is available on MailNews and Message Composition windows.

Expected Results:  
The sidebar be available.

This is not dupe of bug 135070 or bug 165619, because in my case, there is no
Sidebar option on View->Show/Hide menu.

I have download my current mozilla build from
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-i686-pc-linux-gnu.tar.gz
Someone removed sidebar from Mozilla Mail - see:
bug 168670 and bug 162785.
I think this was bad idea. Mozilla Mail needs sidebar !!!

Updated

17 years ago
QA Contact: olgam → laurel

Comment 2

17 years ago
User comment here... I think removing sidebar from mail was a bad idea.  I built
a custom sidebar which gives me status reports on my servers (automatically
refreshes every 5 min).  Now there is no way for me to see this information when
i am using mail.  Is it so hard to just make this a toggle-able action?  Leave
it off by default if you want, but please bring back the sidebar to mail/news.

Its so bad for me I may re-install 1.1.
Reporter

Comment 3

17 years ago
I fully agree with you Peter. The MailNews is the main windown of my Mozilla,
and I used to access address book and bookmarks directly from it's sidebar.

I haven't understood yet why it was removed.

Comment 4

17 years ago
*** Bug 187173 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
Why aren't you people voting for this bug ?  Merely posting your comments will
not get this issue the attention it deserves.  If we are to have the even the
tiniest chance to get Seth to undo this evil thing he has done, we need to get
votes on this.   

It is absolutely disgusting that Seth could file bug #168670 and then get the
sidebar removed without first garnishing *major* support for that idiotic idea.
Not only did he not get major support - he got NO support.  NOBODY voted for
that bug and NOBODY posted a comment in favour of that bug.

When you look at the first five dozen messages in #168670, you will see that
they are *ALL* from Seth Spitzer.  In a span of just 39 *MINUTES* he proposed
the idea, posted a patch, "accepted" it, and wrote it off as over and done with.
Not only did he not first garner support for his idea, but because of that 39
minute time span he never even gave anybody the chance to comment on it first.
This is an outrageous abuse of his authority and he should be strongly censured
for it.  

A 39 *DAY* review period before removing such a major feature from Mail/News
would have been too short.The way Seth bulled his way through the process
strongly suggests that he *knew* no one would support his bug and he knew he had
to push his "patch" through before anyone had a chance to object.

I would further propose that in the future, anyone who wants to do something
that has such a crippling effect on Mozilla should be required to get at *least*
20 votes before being allowed to do anything.   

I totally agree with  Rob Stow (and I'm already voted ;)

Happy New Year !!!

Updated

17 years ago
Flags: blocking1.3b+

Comment 7

17 years ago
nominating for decision on whether sidebar is in or out, if need be and we have
a split decision moz vs. commercial, I can log an internal/bugscape bug
Keywords: nsbeta1

Comment 8

17 years ago
eglyte, please don't set flags if you don't know how to use them.
Flags: blocking1.3b+

Comment 9

17 years ago
Mail triage team: nsbeta1-
Keywords: nsbeta1-

Updated

17 years ago
Keywords: nsbeta1
The module owner has spoken. He removed the sidebar and that's his decision to
make. Filing bugs for reversing decisions of module owners is a waste of time
and resources. If you don't like it then I encourage you to take the code and
make a better mail client or stick with any one of the dozens of older
milestones that had that feature. This isn't a democracy; it's a meritocracy and
Seth has earned his spot as Mozilla Mail Module Owner which gives him the right
to make these kinds of decisions. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 11

17 years ago
I think closing bug with ~20 votes and making resolution WONTFIX it's at least
not polite.
Mozilla developers should ask users before removing any important features and
should admit if make a mistake (like in this case).
I think this bug should reopened or _really_ fixed ASAP.

Comment 12

16 years ago
I Start Mozilla from MailNews and rely on the sidebar to access my Bookmarks and
WWW home page. This is an important feature as far as I' concerned. Would love
to have it back.

Comment 13

16 years ago
Reporter, maybe you can reopen this bug ?
Many people like sidebar in MailNews and there are also other bugreports about
this, see bugs #187173 and #135070

Comment 14

16 years ago
also see bug #178376
Reporter

Comment 15

16 years ago
According to Asa Dotzler (comment #13), this is a "waste of time and resources".
I'm in no way satisfied with Mozilla developers' decision, I'm still missing
about WHY their efforts are used on removing useful features without giving
explanation to the users while there is a lot of serious bugs sitting around,
asking for resolution.

But, above all, I don't want to begin a fight with the Mozilla developers. If
they think this is waste of time and resources, I wont give my suggestions anymore.

If you think sidebar should be back, fell free to open a new bug report and
argue with them if this is a waste. If you do so, and if your bug report survive
enough, I will surely give it my vote.

If there is not enough reason, I wont reopen this bug. I (like most people) hate
having my suggestions being discarded like this, without explanation.
OS: Linux → All
Reporter

Comment 16

16 years ago
Errata on last comment. Aza Dotzler comment is comment #10.

Updated

16 years ago
Summary: Unable to display the sidebar on mailnews and compose windows → Restore access to Sidebar from Mail/News, Compose and Addressbook

Updated

16 years ago
Blocks: 61305

Comment 17

16 years ago
adding a whole bunch of bugs in the mailnews sidebar to the list blocked by this
bug, at the request of timeless.

Updated

16 years ago
No longer blocks: 200921

Updated

16 years ago
Blocks: 58587
Product: Browser → Seamonkey
Looking at restoring the sidebar in the New Suite...
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Posted patch Patch for Message Compose (obsolete) — Splinter Review
Assignee: sspitzer → neil.parkwaycc.co.uk
Status: REOPENED → ASSIGNED
Attachment #179499 - Flags: superreview?(bienvenu)
Attachment #179499 - Flags: review?(bugzilla)

Updated

14 years ago
Attachment #179499 - Flags: superreview?(bienvenu) → superreview+
Comment on attachment 179499 [details] [diff] [review]
Patch for Message Compose

There are some problems with the way this works and displays (which may be
related):

1) Sidebar title doesn't look the same as the browser. I'd expect it to.
2) When tabs are selected for display you get a blank rectangle of colour at
the bottom of the sidebar display - you then can't change sidebar view, except
by re-choosing which tab to display.
3) There is this error on the command line output for right clicking on the
compose window sidebar which doesn't happen in the browser:

JavaScript error:
chrome://messenger/content/messengercompose/messengercompose.xul, line 1:
contentAreaClick is not defined

Other nits:

-	       <menuitem id="menu_showTaskbar"
-			 type="checkbox"/>
+	       <menuitem id="menu_showTaskbar"/>

I don't see why you are removing the type="checkbox" here. Additionally we end
up with two Show Status Bar options in the View->Show/Hide menu, the second of
which doesn't work.

+    <menuitem label="&toButton.label;" accesskey="&toButton.accesskey;"
oncommand="AbPanelAdd('addr_to');" default="true"/>
...
     <menuitem label="&composeEmail.label;"
accesskey="&composeEmail.accesskey;" oncommand="AbNewMessage();"
default="true"/>

Hmm, not sure about these both being default=true - only one of them turns up
highlighted on the popup menu.

Can we also add a check for blank primary email addresses and warn the user if
they try to add one that is blank? Currently it just does nothing, which may be
confusing (xref select addresses dialog - if you click to/cc/bcc it prompts).
Attachment #179499 - Flags: review?(bugzilla) → review-

Updated

14 years ago
Depends on: 289366
Change Log:
* Added prompt for card without primary email address
* Fixed JS errors for left and right clicks in sidebar
* Fixed Show/Hide Status Bar
* Centralized overlay of sidebar.css
Attachment #179499 - Attachment is obsolete: true
Attachment #180967 - Flags: review?(bugzilla)
Comment on attachment 180967 [details] [diff] [review]
Fixed patch for message compose

r=me.
I think we should also make the address book panel one of the default ones in
the profile, as otherwise the user may not realise about it (we can always do
this in a seperate bug).
Attachment #180967 - Flags: review?(bugzilla) → review+
Comment on attachment 180967 [details] [diff] [review]
Fixed patch for message compose

Just checking as there have been a few changes since the original
superreview...
Attachment #180967 - Flags: superreview?(bienvenu)

Comment 24

14 years ago
Comment on attachment 180967 [details] [diff] [review]
Fixed patch for message compose

One nit - the comment here might explicitly refer to the menu items being
enabled/disabled - I guess it's unlikely the menu items will ever change, but
it would make it easier if they did to have a comment in the code.

+  gMsgCompose = parent.document.documentElement.getAttribute("windowtype") ==
"msgcompose";
+  for (var i = 0; i < 4; i++)
+    popup.childNodes[i].hidden = !gMsgCompose;
+  popup.childNodes[4].hidden = gMsgCompose;
Attachment #180967 - Flags: superreview?(bienvenu) → superreview+

Updated

14 years ago
Attachment #180967 - Flags: approval1.8b2?
Comment on attachment 180967 [details] [diff] [review]
Fixed patch for message compose

a=asa
Attachment #180967 - Flags: approval1.8b2? → approval1.8b2+

Comment 26

14 years ago
Mark, I think you broke help viewer's side bar with this patch (well lost its
style) - used to pulled in sidebar.css via navigator.css. Following line
inserted after line 2 in help.xul seems to fix it but not sure if that is the
best way to do it.
<?xml-stylesheet href="chrome://communicator/skin/sidebar/sidebar.css"
type="text/css"?>

Comment 27

14 years ago
Ooops, it was Neil that broke it, not Mark, sorry :-S

Updated

14 years ago
Blocks: 293198

Comment 28

14 years ago
Spun off the problem into 293198
*** Bug 241121 has been marked as a duplicate of this bug. ***

Comment 30

13 years ago
The way I use Mozilla / SeaMonkey, an icon "Bookmarks" in the icon bar would already be enough, but a tabbed sidebar with a Bookmarks tab would be fine, too.
Neil,
Are you still working on this ?
No, I'm not actively working on this; Mail/News and Addressbook still remain.
Assignee: neil → mail
Status: ASSIGNED → NEW
QA Contact: laurel

Updated

8 years ago
No longer blocks: 160366
Depends on: 713563

Comment 33

4 years ago
On de.comm.software.mozilla.misc "SM: Bugs bestätigen 2015-02 -- Bug 200921 - Schnelle Abfolge Klick -> Rechtsklick wird als Doppelklick gewertet" some users tried to reproduce the problem - without success.

Tested OS: 
Win 7 Ultimate / SM 2.32.1 
Windows 7 Professional 64bit
SM 2.32.1 / XP Prof SP3

Anybody here who still can observe the problem (or can leave a statement concerning patch attempts above?

Comment 34

4 years ago
If the bug seems related, someone should add "Bug 200921 - left click followed by right click in folder pane is taken as a double click" to "See Also"

Comment 35

4 years ago
I've implemented it for MailNews and Address book. It's not completely ready, since it restores sidebar height incorrectly. Can I get a preliminary feedback?

Comment 36

4 years ago
This patch adds support for non-full-height sidebars that will be used in MailNews and Address book.

Actually the old code was still there, but it has several problems that make it completely unsuitable for this:
1. It assumes that Folder Pane or Directory Pane on top of the sidebar is a part of the sidebar. Back then there weren't any options for toggling panes, so it worked well. Now it would seriously break those, as well as mail tabs.
2. Dynamic layout switching in MailNews will not work, since you can't move sidebar out of folder pane, because the whole left pane is the sidebar.
3. Since we have sidebar hidden by default, it would hide Folder pane and Directory pane as well.
Attachment #8626672 - Flags: feedback?

Comment 37

4 years ago
Sidebar for MailNews window
Attachment #8626673 - Flags: feedback?

Comment 38

4 years ago
Sidebar for Address book
Attachment #8626674 - Flags: feedback?

Comment 39

4 years ago
Sidebar for single message window

Comment 40

4 years ago
Posted patch modern.patchSplinter Review
Modern theme update, fixes splitter borders around the sidebars. Classic is fine as is, no need to update.

Updated

4 years ago
Attachment #8626677 - Flags: feedback?

Updated

4 years ago
Attachment #8626675 - Flags: feedback?

Comment 41

4 years ago
Posted image mailnews-sidebar.png
Screenshot of the patches

Updated

4 years ago
Attachment #8626673 - Attachment description: MailNews window → messenger.patch

Updated

4 years ago
Attachment #8626674 - Attachment description: Address book → addressbook.patch

Updated

4 years ago
Attachment #8626675 - Attachment description: Message window → messageWindow.patch

Comment 42

4 years ago
Additionally, the Address book sidebar panel is present in Address book itself. It seems to work, but perhaps it would make sense to disable it there, or at least uncheck by default.

Folder pane and Directory pane shortcuts are now Shift+F9 instead of F9, which is used for the sidebar in both components.

Updated

4 years ago
Attachment #8626672 - Flags: ui-review?
Attachment #8626672 - Flags: feedback?(neil)
Attachment #8626672 - Flags: feedback?(mnyromyr)
Attachment #8626672 - Flags: feedback?

Updated

4 years ago
Attachment #8626673 - Flags: feedback?(neil)
Attachment #8626673 - Flags: feedback?(mnyromyr)
Attachment #8626673 - Flags: feedback?

Updated

4 years ago
Attachment #8626674 - Flags: feedback?(neil)
Attachment #8626674 - Flags: feedback?(mnyromyr)
Attachment #8626674 - Flags: feedback?

Updated

4 years ago
Attachment #8626675 - Flags: feedback?(neil)
Attachment #8626675 - Flags: feedback?(mnyromyr)
Attachment #8626675 - Flags: feedback?

Updated

4 years ago
Attachment #8626677 - Flags: feedback?(neil)
Attachment #8626677 - Flags: feedback?(mnyromyr)
Attachment #8626677 - Flags: feedback?

Updated

4 years ago
Attachment #8626672 - Flags: ui-review?
You need to log in before you can comment on or make changes to this bug.