google.com saved as bookmark, but browser defaults to google.fr

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
16 years ago
14 years ago

People

(Reporter: Ronnie Aker, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016

previous Mozilla did not have this problem, it's driving me crazy, google.com is
only saved for individual session, not later ones

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Sounds like google is automatically redirecting you based on a cookie value
(google.com does that if you have one of the "language" cookies that google sets).

Comment 2

16 years ago
Google also redirects based on Accept-Language (I believe).

google.com (but not the internationals) has also recently started to force
redirects to google.fr and google.de for legal reasons, based upon the source IP
address of the request.

However, it is possible to override that with a cookie, I believe, so this may
still be a valid bug.

Reporter, could you provide a more detailed set of steps to reproduce, starting
from a blank default profile, please?.  Note that an implicit first step might
be 'be in France', so testing might be a little tricky.

Comment 3

16 years ago
An alternative approach to test if this is a Mozilla bug would be trying other
browsers.

Reporter, if you have other browsers installed, please try entering
"www.google.com" there and see if you are also redirected. Then, this can not be
a Mozilla bug, because google looks where you are and then takes you to the
corresponding national site.

Comment 4

16 years ago
Being connected directly to the internet, google.com redirects me to google.de
(I live in Germany and use a german internet access provider.)

However, I just entered an open proxy (located in the USA) as my internet access
under preferences. Now google.com does NOT redirect me.

So, as assumed in comment #2, google.com does an automatical redirect based on
the client IP and this is not a Mozilla bug IMO (->invalid). When it comes to
the overriding cookie... I don't know the reporter has set one...
I also do only know of one that sets the language used when google interacts
with you. But that one does not affect the Top Level Domain you are redirected to.
(I just had google.de using french language.)

Comment 5

16 years ago
resolving INVALID, per previous comments. this is not a mozilla bug - mozilla is
just following google's redirect.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 6

16 years ago
The U.S. Google site seems to be the one site of theirs you can't "force" access
to by typing the direct address instead of letting their redirect take you where
they think you should go... they've registered google.us but it doesn't resolve.
 It would be more globally symmetrical for them to use google.us for the U.S.
site and have google.com always redirect to the appropriate site (including .us)
depending on where you are (or at least where they think you are).
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.