Closed Bug 1780967 Opened 2 months ago Closed 2 months ago

Update opus to new version ab04fbb1b7d0b727636d28fc2cadb5df9febe515 from 2022-07-24 03:46:16

Categories

(Core :: Audio/Video: Playback, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
105 Branch
Tracking Status
firefox104 --- wontfix
firefox105 --- fixed

People

(Reporter: update-bot, Assigned: kinetik)

References

Details

(Whiteboard: [3pl-filed][task_id: GnWQrP8YSTefNZO7hvl2nA])

Attachments

(1 file)

This update covers 7 commits, including 3 new upstream commits I've never filed a bug on before. (They're the top 3.):


ab04fbb1b7d0b727636d28fc2cadb5df9febe515 by Jean-Marc Valin

https://gitlab.xiph.org/xiph/opuscommit/ab04fbb1b7d0b727636d28fc2cadb5df9febe515
Authored: 2022-07-24 03:46:16 -0400
Committed: 2022-07-24 03:46:16 -0400

Smooth out the LBRR rate estimate

Reduces fluctuations in the non-FEC target bitrate.

Files Modified:

  • silk/enc_API.c

fd9c0f1e1f1b74c46c5872217e3289a9edf69d48 by Jean-Marc Valin

https://gitlab.xiph.org/xiph/opuscommit/fd9c0f1e1f1b74c46c5872217e3289a9edf69d48
Authored: 2022-07-24 02:14:53 -0400
Committed: 2022-07-24 02:16:03 -0400

More FEC tuning: lowering the LBRR bitrate a bit

Files Modified:

  • silk/control_codec.c

5413ef784941652448e703688fbe3b96ef6d7e86 by Jean-Marc Valin

https://gitlab.xiph.org/xiph/opuscommit/5413ef784941652448e703688fbe3b96ef6d7e86
Authored: 2022-07-24 02:12:03 -0400
Committed: 2022-07-24 02:12:03 -0400

Re-tuning the use of LTP scaling

Making LTP scaling depend on the bitrate and whether FEC is on.
The thresholds for scaling 1 and 2 are now independent.

Files Modified:

  • silk/fixed/LTP_scale_ctrl_FIX.c
  • silk/float/LTP_scale_ctrl_FLP.c

378b4e5fc31b63c1f1a9f6a87a62609c5a083724 by Jean-Marc Valin

https://gitlab.xiph.org/xiph/opuscommit/378b4e5fc31b63c1f1a9f6a87a62609c5a083724
Authored: 2022-07-22 02:53:39 -0400
Committed: 2022-07-22 12:22:47 -0400

Ensuring we can see where crashes occur

Reviewed by Mark Harris

Files Modified:

  • tests/test_opus_encode.c

4c6bae5078be71b0a4d69d0c3fa77a5a849f9876 by Jean-Marc Valin

https://gitlab.xiph.org/xiph/opuscommit/4c6bae5078be71b0a4d69d0c3fa77a5a849f9876
Authored: 2022-07-22 02:32:04 -0400
Committed: 2022-07-22 12:22:41 -0400

More ubsan fixes for the debug macros themselves

Reviewed by Mark Harris

Files Modified:

  • silk/MacroDebug.h

e05aea9785f709f5aebb696ee5b4460681676e10 by Jean-Marc Valin

https://gitlab.xiph.org/xiph/opuscommit/e05aea9785f709f5aebb696ee5b4460681676e10
Authored: 2022-07-22 02:29:05 -0400
Committed: 2022-07-22 12:22:34 -0400

Using saturating round to fix some wrap-arounds

Reviewed by Mark Harris

Files Modified:

  • celt/celt_decoder.c
  • celt/celt_lpc.c

fbed746cb2d0fee57eae090e67d148d89923f6ff by Jean-Marc Valin

https://gitlab.xiph.org/xiph/opuscommit/fbed746cb2d0fee57eae090e67d148d89923f6ff
Authored: 2022-07-22 02:27:34 -0400
Committed: 2022-07-22 12:22:12 -0400

Relaxing checks for MULT16_32_QX()

MULT16_32_QX() is now implemented using a signed-unsigned multiply,
so the second argument can now have one extra bit compared to the
old signed-signed implementation.

Reviewed by Mark Harris

Files Modified:

  • celt/fixed_debug.h

Duplicate of this bug: 1780854

All the jobs in the try run succeeded. Like literally all of them, there weren't
even any intermittents. That is pretty surprising to me, so maybe you should double
check to make sure I didn't misinterpret things and that the correct tests ran...

Anyway, I've done all I can, so I'm passing to you to review and land the patch.
When reviewing, please note that this is external code, which needs a full and
careful inspection - not a rubberstamp.

Assignee: nobody → kinetik
Pushed by mgregan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/332146c0144b
Update opus to ab04fbb1b7d0b727636d28fc2cadb5df9febe515 r=kinetik
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch
You need to log in before you can comment on or make changes to this bug.