Java applet entropy gathering fails on Chimera, succeeds on Mozilla

RESOLVED FIXED

Status

Camino Graveyard
Plug-ins
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: ticklestone, Assigned: smichaud)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
Chimera Build ID: 2002110104

The above site is not displayed. You need to move the mouse to produce some
entropy. It seem that chimera does not handle this.

Comment 1

16 years ago
Michael, please provide an example URL.
(Reporter)

Comment 2

16 years ago
I am sorry, I thought I had given the URL.
This is the URL:
https://banking.rwso.de/ksk-tut/

Comment 3

16 years ago
I think I see this using Chimera/2002110204 on 10.1.5. Michael, does the page
use mouse movement to generate some sort of random number? I don't understand
the language in use (Dutch?) so I can't be sure.

Using FizzillaCFM/2002103011, moving the mouse does result in something happening.
(Reporter)

Comment 4

16 years ago
> Michael, does the page use mouse movement to generate some sort of random number?

Yes, you need to move the mouse and the applet is gathering some entropy to
setup a secure connection at 512 bit. While moving the mouse, you see a counter
in the bottom counting from 0 to 100%. Chimera does not show the counter,
instead you see Loading images... for ever. It seems Chimera has some problems
with a Java implementations to gather the mouse movement. Since Mozilla 1.2.
Beta can handle that page, it is not a Java problem by Apple's Java kit.

I am using 10.2.1 and the problem occured with all builds of Navigator.

Comment 5

16 years ago
Okay, I'll mark this confirmed since I see it using Chimera/2002110415 on
10.1.5. Reassigning to Plug-ins, but I suppose it could still be a browser
detection problem.
Assignee: saari → bnesse
Status: UNCONFIRMED → NEW
Component: General → Plug-ins
Ever confirmed: true
QA Contact: winnie → petersen
Summary: Java Applet Problem - gathering Entropy → Java applet entropy gathering fails on Chimera, succeeds on Mozilla
(Reporter)

Comment 6

16 years ago
> I suppose it could still be a browser detection problem.

No, definitely not. The compatibility of the browser is checked by the
html-document before the applet is loaded. Also the page will check if the
Java-Version is installed and compatible before the applet is loaded.

If you use an incompatible browser or java-version then you will receive an
error html, showing you which browsers and java-versions are supported.

Comment 7

16 years ago
Related to bug 172807: the plugin isn't getting mouse move events.

Updated

13 years ago
Blocks: 224615

Updated

13 years ago
Assignee: bnesse → sfraser_bugs
Is this still a problem with Apple's plugin or the Java Embedding Plugin and a
recent Camino?

Is there another testcase for this?  I can't get the URL provided to load.
Can we get a new testcase on this?  

Is the problem only that the applet doesn't get mouse events (comment 7)?  If
so, that's fixed with the JEP (might have worked with Apple's Java plugin, too).

Comment 10

13 years ago
-> Stephen, JEP author. Feel free to close if this works with the most recent JEP.
Assignee: sfraser_bugs → smichaud
(Assignee)

Comment 11

13 years ago
The test URL still isn't accessible ... and hasn't been for several months,
apparently.  It also looks very unlikely that we'll get a new one.

So I can't do any testing.  But it seems pointless to leave this open.  If in
a few days I haven't received any objections, I'll close it and mark it
"fixed".

(Reporter)

Comment 12

13 years ago
The problem is, the URL has changed and that they don't use mouse movements
anymore to gather entropy. So there is probably no site available to test the
mouse movement gathering thing...
(Assignee)

Comment 13

13 years ago
Thanks for letting us know.  If the matter ever comes up again, and if this
problem turns out not to have been solved by the Java Embedding Plugin, we can
reopen this bug.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.