crash clicking on a link (that dismisses the window).

RESOLVED WORKSFORME

Status

()

Core
Event Handling
--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: John Morrison, Assigned: saari (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
1) Go to http://whistler.rezrez.net/vps/
2) Click on the calendar icon for 'Start Date'
3) Click on one of the days

Actual result: crash. |mLinkHandler| in nsPresContext is 
               non-null, but garbage

I can hit this crash everytime in my own trunk build, but have only managed
to reproduce once with the current (11/02) trunk release build. [However, 
I do have some changes in my tree, particularly kmcclusk's reflow changes
(although I don't see how those would directly affect this code path).]

jpatel: can you see if there are (m)any similar stack traces in talkback?

Call stack from my optimized build with symbols:

nsPresContext::GetLinkHandler(nsPresContext * const 0x03140c90, nsILinkHandler *
* 0x0012f560) line 1496 + 10 bytes
nsGenericElement::TriggerLink(nsGenericElement * const 0xfeeefeee,
nsIPresContext * 0x03140c90, nsLinkVerb eLinkVerb_Replace, nsIURI * 0x01bb2ea0,
const nsString & {...}, const nsString & {...}, int 0x00000001) line 3063
nsGenericHTMLElement::HandleDOMEventForAnchors(nsGenericHTMLElement * const
0xfeeefeee, nsIContent * 0x0316a280, nsIPresContext * 0x03140c90, nsEvent *
0x01bb2ea0, nsIDOMEvent * * 0x00000000, unsigned int 0x0316a2a8, nsEventStatus *
0x0012f9c0) line 1493 + 30 bytes
nsHTMLAnchorElement::HandleDOMEvent(nsHTMLAnchorElement * const 0x0316a280,
nsIPresContext * 0x03140c90, nsEvent * 0x0012f804, nsIDOMEvent * * 0x0012f73c,
unsigned int 0x00000002, nsEventStatus * 0x0012f9c0) line 359
nsGenericDOMDataNode::HandleDOMEvent(nsGenericDOMDataNode * const 0x0316a4f0,
nsIPresContext * 0x03140c90, nsEvent * 0x00000000, nsIDOMEvent * * 0x0012f73c,
unsigned int 0x00000001, nsEventStatus * 0x0012f9c0) line 826 + 21 bytes
PresShell::HandleEventInternal(PresShell * const 0xfeeefeee, nsEvent *
0x03143138, nsIView * 0x00000000, unsigned int 0x00000001, nsEventStatus *
0x0012f9c0) line 6244 + 21 bytes
PresShell::HandleEventWithTarget(PresShell * const 0x03140ee0, nsEvent *
0x0012f804, nsIFrame * 0x031be0b0, nsIContent * 0x0316a4f0, unsigned int
0x00000001, nsEventStatus * 0x0012f9c0) line 6214
nsEventStateManager::CheckForAndDispatchClick(nsEventStateManager * const
0xfeeefeee, nsIPresContext * 0x03140c90, nsMouseEvent * 0x03140ee0,
nsEventStatus * 0x0012f9c0) line 2877
nsEventStateManager::PostHandleEvent(nsEventStateManager * const 0x03143138,
nsIPresContext * 0x03140c90, nsEvent * 0x0012fa8c, nsIFrame * 0x031be0b0,
nsEventStatus * 0x0012f9c0, nsIView * 0x03150bc0) line 1869 + 15 bytes
PresShell::HandleEventInternal(PresShell * const 0xfeeefeee, nsEvent *
0x03143138, nsIView * 0x03150bc0, unsigned int 0x00000001, nsEventStatus *
0x0012f9c0) line 6264 + 23 bytes
PresShell::HandleEvent(PresShell * const 0x03143138, nsIView * 0x03150bc0,
nsGUIEvent * 0x0012fa8c, nsEventStatus * 0x0012f9c0, int 0x00000000, int &
0x00000001) line 6167 + 18 bytes
nsViewManager::HandleEvent(nsViewManager * const 0xfeeefeee, nsView *
0x00000000, nsGUIEvent * 0x0012fa8c, int 0x00000000) line 2209
nsView::HandleEvent(nsView * const 0xfeeefeee, nsViewManager * 0x0308dc80,
nsGUIEvent * 0x0012fa8c, int 0x00000000) line 304
nsViewManager::DispatchEvent(nsViewManager * const 0x0308dc80, nsGUIEvent *
0x03150998, nsEventStatus * 0x0012fa3c) line 1943 + 30 bytes
HandleEvent(nsGUIEvent * 0x0012fa8c) line 83
nsWindow::DispatchEvent(nsWindow * const 0x03150a3c, nsGUIEvent * 0x0012fa8c,
nsEventStatus & nsEventStatus_eIgnore) line 1073
nsWindow::DispatchWindowEvent(nsWindow * const 0xfeeefeee, nsGUIEvent *
0x00000000) line 1090
nsWindow::DispatchMouseEvent(nsWindow * const 0xfeeefeee, unsigned int
0x0000012d, unsigned int 0x00000000, nsPoint * 0x00000000) line 5284
ChildWindow::DispatchMouseEvent(ChildWindow * const 0xfeeefeee, unsigned int
0x0000012d, unsigned int 0x00000000, nsPoint * 0x00000000) line 5538 + 19 bytes
nsWindow::ProcessMessage(nsWindow * const 0xfeeefeee, unsigned int 0x00000202,
unsigned int 0x00000000, long 0x006000b9, long * 0x0012fd0c) line 4065 + 17 bytes
nsWindow::WindowProc(HWND__ * 0x01650510, unsigned int 0x00000000, unsigned int
0x00000000, long 0x03150a3c) line 1338 + 16 bytes
USER32! 77e13eb0()
USER32! 77e1401a()
USER32! 77e192da()
nsAppShellService::Run(nsAppShellService * const 0x00f3c008) line 472
main1(int 0x00000000, char * * 0x1004d0f8 const  nsObserverService::`vftable',
nsISupports * 0x00000000) line 1522 + 9 bytes
main(int 0x00000001, char * * 0x00254178) line 1883 + 27 bytes
WinMain(HINSTANCE__ * 0x00400000, HINSTANCE__ * 0x00400000, char * 0x001330b9,
HINSTANCE__ * 0x00400000) line 1905 + 23 bytes
MOZILLA! WinMainCRTStartup + 308 bytes
KERNEL32! 77e87903()


Although talkback sez it's this instead (slightly different):


0x00ed476e
nsWebShell::OnLinkClick
[d:/builds/seamonkey/mozilla/docshell/base/nsWebShell.cpp, line 546]
nsGenericElement::TriggerLink
[d:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 3099]
nsGenericHTMLElement::HandleDOMEventForAnchors
[d:/builds/seamonkey/mozilla/content/html/content/src/nsGenericHTMLElement.cpp,
line 1495]
nsHTMLAreaElement::HandleDOMEvent
[d:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLAreaElement.cpp,
line 233]
nsGenericDOMDataNode::HandleDOMEvent
[d:/builds/seamonkey/mozilla/content/base/src/nsGenericDOMDataNode.cpp, line 829]
PresShell::HandleEventInternal
[d:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6246]
PresShell::HandleEventWithTarget
[d:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6214]
nsEventStateManager::CheckForAndDispatchClick
[d:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 2877]
nsEventStateManager::PostHandleEvent
[d:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 1871]
PresShell::HandleEventInternal
[d:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6267]
PresShell::HandleEvent
[d:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6169]
nsViewManager::HandleEvent
[d:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2209]
nsView::HandleEvent [d:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 304]
nsViewManager::DispatchEvent
[d:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1949]
HandleEvent [d:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[d:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1074]
nsWindow::DispatchWindowEvent
[d:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1091]
nsWindow::DispatchMouseEvent
[d:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 5208]
nsWindow::DispatchFocus
[d:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 5462]
nsWindow::ProcessMessage
[d:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 4060]
nsWindow::WindowProc
[d:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1339]
USER32.DLL + 0x3eb0 (0x77e13eb0)
USER32.DLL + 0x401a (0x77e1401a)
USER32.DLL + 0x92da (0x77e192da)
nsAppShellService::Run
[d:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 472]
main1 [d:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1538]
main [d:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1886]
WinMain [d:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1906]
WinMainCRTStartup()
KERNEL32.DLL + 0x7903 (0x77e87903)

Updated

16 years ago
QA Contact: rakeshmishra → trix
*** Bug 189346 has been marked as a duplicate of this bug. ***
Use the testcase in bug 189346 and you can easy crash (if you know how :-) )

Comment 3

15 years ago
WFM, 2003-06-07-05 trunk Linux.
http://whistler.rezrez.net/vps/ and the testcases from bug 189346 does not crash
and seems to work as expected.

Comment 4

15 years ago
.
Assignee: joki → saari
QA Contact: trix → ian

Comment 5

14 years ago
WFM. Entering the URL, clicking the start date calendar icon, selecting a day.
No crash. Tried several times, reloading the page and selecting other days, no
crashes whatsoever.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040330
Microsoft Windows 2000 Pro 5.00.2195 SP4

Comment 6

14 years ago
unable to reproduce with windows Mozilla 1.7 beta 
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.