mozilla does not free memory

RESOLVED INVALID

Status

SeaMonkey
UI Design
--
major
RESOLVED INVALID
16 years ago
13 years ago

People

(Reporter: Maros Ivanco, Assigned: Samir Gehani)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021102
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021102

When I open any web page either in tab or new window, mozilla allocates some
portion of memory. If I close the tab or window, the memory remains allocated.

Reproducible: Always

Steps to Reproduce:
1. browse with mozilla
2. and see stats in task manager
3.



Expected Results:  
mozilla should free memory
Marking invalid, since this bug contains no useful information.

Typically, Mozilla's memory usage will increase some at first as various memory
caches fill up.  If you have a specific testcase that causes unbounded memory
growth as the same page is loaded over and over, file a bug on that, please. 
But without a specific testcase, there's no guarantee that this is even a bug
and certainly no way to do anything about it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

16 years ago
I have memory and disk cache set to zero. Initial size of mozilla uses 8MB. I
browse for a while, the pages are not bigger than 100kB, mozilla uses 38MB. I
close  all tabs and windows (but one) and load into last really simple page with
no content. Mozilla uses 38MB. I wait 30 minutes, mozilla uses 36MB. If this is
normal and caused by caches, is there any possibility to disable them?
Some of that is caused by us releasing memory but your C library being unable to
free the memory back to the OS.  So we end up being approximately the size we
had to be to render the biggest page we loaded....  With how little information
you gave me, I can't say how much of the memory usage that one issue accounts
for here.

Note that the number is then misleading, since Mozilla may in fact only be using
a few MB of the memory it has allocated and the rest can be swapped out without
affecting operation in any way....
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.