make links absolute when saving HTML pages

RESOLVED WORKSFORME

Status

Core Graveyard
File Handling
--
enhancement
RESOLVED WORKSFORME
16 years ago
2 years ago

People

(Reporter: Matthew Rochlin, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
In the browser, when opting under the File Menu to "save page as", it'd be really nice if there was at least the option to save the page with absolute links instead of relative links.   Then you could navigate using the links on the saved page.  As it is, on most pages, all the links on a saved page are useless.  (e.g.  instead of href="enter_bug.cgi" you could convert it to href="http://bugzilla.mozilla.org/enter_bug.cgi").
It'd be nice if it was an option because sometimes people just want to see what's on the real page.   Speaking of that - when you save HTML it saves with a bunch of Mozilla inserted scripts that weren't in the orignal HTML.  That is a bug.
Thanks.
1) Which build of Mozilla are you using? ALWAYS list this.
2) Are you saving "web page, complete" or "web page, HTML only"?

Updated

16 years ago
Summary: save absolute URLs when saving HTML pages → make links absolute when saving HTML pages

Comment 2

16 years ago
No response from reporter for >30 days. resolving WORKSFORME.

Reporter: If you can reproduce this with a recent build of Mozilla, then please
reopen this bug and give details. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.