|nsCOMPtr| has |dont_QueryInterface| outlived its usefulness?

RESOLVED DUPLICATE of bug 209852

Status

()

RESOLVED DUPLICATE of bug 209852
16 years ago
15 years ago

People

(Reporter: scc, Assigned: scc)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

16 years ago
People now `get' the model that |nsCOMPtr| only does a QI when commanded to. 
|dont_QueryInterface| is no longer needed to highlight |nsCOMPtr|s lack of
action; in fact now, it may be a hindrance to new readers.  Removing it from the
code might make things clearer and simpler.
(Assignee)

Comment 1

16 years ago
An LXR search (see URL above) shows less than two pages of hits.
Blocks: 178174
Status: NEW → ASSIGNED
Oops, I should have searched before I filed a duplicate.  Anyway, this is
already fixed in bug 209852.

*** This bug has been marked as a duplicate of 209852 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.