Open Bug 1782007 Opened 2 months ago Updated 2 months ago

"LOAD COMMENTS" button does not work on sammobile.com with ETP set to Strict

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

Firefox 105
Desktop
Windows 10
defect

Tracking

()

Tracking Status
firefox105 --- affected

People

(Reporter: calin.tanase, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

Attached image Sammobile.gif

Environment:
Operating system: Windows 10
Firefox version: Nightly 105.0a1 (2022-07-27) (64-bit)

Preconditions:
ETP set to STRICT
Clean profile

Steps to reproduce:

  1. Go to https://www.sammobile.com/at-100-off-the-galaxy-a53-5g-is-an-absolute-steal
  2. Scroll down until the end of the article is reached
  3. Click on "LOAD COMMENTS" button

Expected Behavior:
The button loads the comments.

Actual Behavior:
The button does not load the comments and the page jumps to initial position.

Notes:

  1. Video provided
  2. Not reproducible with Standard ETP
  3. Reproducible with both Standard and Strict in Private Window
  4. It also adds a "#" at the end of the link
Summary: "LOAD COMMNETS" button does not work on sammobile.com with ETP set to Strict → "LOAD COMMENTS" button does not work on sammobile.com with ETP set to Strict

It's not immediately clear what's happening here, but it's likely that our shims which apply on this page just aren't working with their ad-prebidder script, and the page isn't setting up the event listeners properly for the comment section.

Severity: -- → S3
You need to log in before you can comment on or make changes to this bug.