Closed Bug 1782050 Opened 2 months ago Closed 2 months ago

periodic-update fails to abandon old phab revision

Categories

(Release Engineering :: General, defect)

defect

Tracking

(firefox-esr91 unaffected, firefox-esr102 unaffected, firefox103 unaffected, firefox104 fixed, firefox105 fixed)

RESOLVED FIXED
Tracking Status
firefox-esr91 --- unaffected
firefox-esr102 --- unaffected
firefox103 --- unaffected
firefox104 --- fixed
firefox105 --- fixed

People

(Reporter: jcristau, Assigned: jcristau)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

From https://firefoxci.taskcluster-artifacts.net/DCb4yW4hSq6dJmqt0yAnYQ/0/public/logs/live_backing.log:

++ /usr/bin/arc list
++ grep 'Needs Review'
++ grep -E 'mozilla-beta repo-update'
++ awk 'match($0, /D[0-9]+[^: ]/) { print substr($0, RSTART, RLENGTH)  }'
+ for diff in $($ARC list | grep "Needs Review" | grep -E "${BRANCH} repo-update" | awk 'match($0, /D[0-9]+[^: ]/) { print substr($0, RSTART, RLENGTH)  }')
+ echo 'Removing old request D152636'
Removing old request D152636
+ echo '{"transactions": [{"type":"abandon", "value": true}], "objectIdentifier": "D152636"}'
+ arc call-conduit differential.revision.edit
␛[1m␛[46m USAGE ␛[49m␛[m "arc" is being run noninteractively, but the argument list is missing "--" to indicate end of flags.
␛[1m␛[46m USAGE ␛[49m␛[m When running noninteractively, you MUST provide "--" to all commands (even if they take no arguments).
␛[1m␛[46m USAGE ␛[49m␛[m Learn More: <␛[4mhttps://phurl.io/u/noninteractive␛[m>
␛[1m␛[41m USAGE EXCEPTION ␛[49m␛[m Missing required "--" in argument list.

Looks like this was triggered by the OS update bringing a newer version of arcanist.

Keywords: regression
Regressed by: 1780329
Status: NEW → ASSIGNED
Pushed by jcristau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a10aeb9c8aa5
periodic-updates: pass -- to arc call-conduit. r=releng-reviewers,gbrown DONTBUILD
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.