Closed Bug 1782343 Opened 2 years ago Closed 2 years ago

There should be a right click menu option for pasting as plain text

Categories

(Firefox :: Menus, defect)

Firefox 103
defect

Tracking

()

VERIFIED DUPLICATE of bug 923514

People

(Reporter: wmattw81, Unassigned)

Details

Attachments

(3 files)

Attached image FirefoxVsChrome.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:103.0) Gecko/20100101 Firefox/103.0

Steps to reproduce:

Highlighted some text
Right clicked on my selection
Clicked on Copy
Left clicked in the compose window in Gmail
Right clicked within the compose window in Gmail
Clicked on Paste
(There should be an option underneath Paste that says Paste as plain text)

Actual results:

Pasted the text with formatting

Expected results:

Pasted the text in plain text when I click on the Paste as plain text right click menu option

The Bugbug bot thinks this bug should belong to the 'Firefox::Menus' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Menus
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE

@Alice0775 White

That bug that you have linked to is over 9 years old.

Perhaps change the status of this bug to new and reopen it and maybe this bug report might see some developer love as the previous similar bug report hasn't received any love from the developers.

Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Thanking you :-)

Alice is correct, bug 923514 is the right dupe. I'll follow up there.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → DUPLICATE

@:Gijs (he/him)

bug 923514 [UX] Add "paste as plaintext" context menu option within main content panel. that you linked to is in fact a duplicate of this bug 476837 Add "Paste without formatting" to designMode context menu and that bug is 14 years old.

Both bugs are 7+ years old and no further progress has been made on either. I'd suggest reopening this one and following up here.

Besides this bug report has something the other 2 don't and that's a graphic (see attached above), and you know what they say about a photo, that's its worth a thousand words.

@Ania Please follow up in here, thanks :-)

Here's another graphic, this one shows the current right click menu and the proposed addition to the right click menu.

(In reply to wmattw81 from comment #6)

Both bugs are 7+ years old and no further progress has been made on either. I'd suggest reopening this one and following up here.

Besides this bug report has something the other 2 don't and that's a graphic (see attached above), and you know what they say about a photo, that's its worth a thousand words.

Just because an older bug has seen no activity doesn't mean we should abandon it and start a new bug losing context. In rare cases it makes sense to dupe forwards but outside of that we dupe to the older bug as that tends to maintain the most history. If something is important it can just be added to the older bug. It seems that the older bug has started to see some work happen so now we're at risk of splitting focus.

(In reply to wmattw81 from comment #8)

I've added the people from the CC list from these bugs and added them to the CC list here:

Please don't do this. You're signing folks up for bugmail they may not want. Based on all the bugs they would have been aware of bug 923514 and had the opportunity to subscribe to it if they so desired.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

(In reply to :Gijs (he/him) from comment #21)

(In reply to Ania from comment #17)

Added a JIRA ticket for this to the Quality foundation epic and linked the task.

Do you think you can add an SP estimation to it off the top of your head - assuming the scope is limited to adding a context menu item?

Done. I also have a patch ready from a technical perspective - but we're going to need content design to pick text for this. comment 0 suggests "Paste As Plain Text", but Chrome currently has "Paste and Match Style". Google docs has "Paste without formatting". Can you help confirm with the content design team what we should use? Off-hand the second ("Paste and Match Style") seems clearest about what it does.

My version of Chome doesn't have a confusing "Paste and Match Style", instead it has a straight forward "Paste as plain text" (see Chrome-Edge-Opera-OpenOffice-LibreOffice.jpg attachment). Perhaps you are using a different region and language than me?

Chrome, Edge, & Opera all use "Paste as plain text". OpenOffice & LibreOffice use Paste Special -> Unformatted text.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: