Crash when opening html document.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: m., Assigned: Blake Ross)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021103 Phoenix/0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021103 Phoenix/0.4

Phoenix crashes when opening OpenOffice generated html document.  I wonder if
this could be a duplicate of bug
http://bugzilla.mozilla.org/show_bug.cgi?id=175724 but the document is displayed
correctly in Mozilla 1.1 (well, I don't know if correctly, but doesn't crash)

I will attach a file that causes the crash.

Reproducible: Always

Steps to Reproduce:
1.Open the attached document in browser.
2.
3.

Actual Results:  
Browser crashed.

Expected Results:  
Display the document.

I tried to do some backtrace with gdb, maybe this helps a bit..

Program received signal SIGSEGV, Segmentation fault.
0x40c6d056 in NSGetModule () from /home/majkl/phoenix/components/libuconv.so
(gdb) bt
#0  0x40c6d056 in NSGetModule () from /home/majkl/phoenix/components/libuconv.so
#1  0x40c71916 in NSGetModule () from /home/majkl/phoenix/components/libuconv.so
#2  0x40c713f1 in NSGetModule () from /home/majkl/phoenix/components/libuconv.so
#3  0x40c71582 in NSGetModule () from /home/majkl/phoenix/components/libuconv.so
#4  0x40d7e4bf in NSGetModule () from /home/majkl/phoenix/components/libgfx_gtk.so
#5  0x40d7eed1 in NSGetModule () from /home/majkl/phoenix/components/libgfx_gtk.so
#6  0x40d82184 in NSGetModule () from /home/majkl/phoenix/components/libgfx_gtk.so
#7  0x40d7e46f in NSGetModule () from /home/majkl/phoenix/components/libgfx_gtk.so
#8  0x40d823e8 in NSGetModule () from /home/majkl/phoenix/components/libgfx_gtk.so
#9  0x40d6b774 in NSGetModule () from /home/majkl/phoenix/components/libgfx_gtk.so
#10 0x4105eadd in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#11 0x4105f8dd in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#12 0x4102f13a in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#13 0x4102b75d in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#14 0x4102b3eb in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#15 0x4102b264 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#16 0x4102f13a in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#17 0x40ffe268 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#18 0x40ffe050 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#19 0x40ffde35 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#20 0x40ffdcff in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#21 0x40ffc6f5 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#22 0x40ffbede in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#23 0x40ffa9f6 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#24 0x41008c69 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#25 0x410be360 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#26 0x41008c69 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#27 0x410d5dfa in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#28 0x410d6c31 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#29 0x41008c69 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#30 0x410d8132 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#31 0x410da14b in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#32 0x41008c69 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#33 0x410c6fb7 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#34 0x410c4a93 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#35 0x410c45f0 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#36 0x41008c69 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#37 0x410d1ec6 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
---Type <return> to continue, or q <return> to quit---
#38 0x410d39c2 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#39 0x410027f6 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#40 0x40ffd6bf in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#41 0x40ffc39d in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#42 0x40ffbede in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#43 0x40ffa9f6 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#44 0x410027f6 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#45 0x40ffd6bf in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#46 0x40ffc39d in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#47 0x40ffbede in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#48 0x40ffa9f6 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#49 0x41008c69 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#50 0x4101bc44 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#51 0x410eab76 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#52 0x410ea63e in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#53 0x410e7784 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#54 0x410dd1c6 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#55 0x410e7784 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#56 0x410ec891 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#57 0x41018520 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#58 0x410187f1 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#59 0x41018566 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#60 0x410e7784 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#61 0x410f9ae7 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#62 0x41017ab9 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#63 0x41008c69 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#64 0x410641dc in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#65 0x410413f8 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#66 0x4104d499 in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#67 0x4104d04e in NSGetModule () from /home/majkl/phoenix/components/libgklayout.so
#68 0x4014006b in PL_HandleEvent () from /home/majkl/phoenix/libxpcom.so
#69 0x40140483 in PL_ProcessEventsBeforeID () from /home/majkl/phoenix/libxpcom.so
#70 0x40b344ab in NSGetModule () from
/home/majkl/phoenix/components/libwidget_gtk.so
#71 0x401083fb in nsVoidArray::EnumerateForwards () from
/home/majkl/phoenix/libxpcom.so
#72 0x40b344e8 in NSGetModule () from
/home/majkl/phoenix/components/libwidget_gtk.so
#73 0x40b3ceb7 in NSGetModule () from
/home/majkl/phoenix/components/libwidget_gtk.so
#74 0x4032bf2f in gdk_wm_protocols_filter () from /usr/lib/libgdk-1.2.so.0
#75 0x4035e390 in g_get_current_time () from /usr/lib/libglib-1.2.so.0
---Type <return> to continue, or q <return> to quit---
#76 0x4035e96f in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#77 0x4035eb2b in g_main_run () from /usr/lib/libglib-1.2.so.0
#78 0x4026f6e3 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#79 0x40b3422d in NSGetModule () from
/home/majkl/phoenix/components/libwidget_gtk.so
#80 0x40b1864a in NSGetModule () from
/home/majkl/phoenix/components/libnsappshell.so
#81 0x08053775 in getCountry ()
#82 0x080540a7 in xre_main ()
#83 0x0804e1dd in main ()
#84 0x404d75b0 in __libc_start_main () from /lib/libc.so.6
(Reporter)

Comment 1

16 years ago
Created attachment 105061 [details]
OpenOffice generated html document that causes the crash.

OpenOffice generated html document that causes the crash.

Comment 2

16 years ago
WFM under Mozilla/5.0 (Windows NT 5.0; en-US; rv:1.2b) Gecko/20021103 Phoenix/0.4

Comment 3

16 years ago
Reporter, can you also try the latest nightly Mozilla and see if the crash
occurs there too? Mozilla 1.1 is not new enough to compare with Phoenix.
(Reporter)

Comment 4

16 years ago
no, I can't test it with mozilla nightly.. it would take me too much time to
download it..
that's why I posted the html file that causes the crash, so some1 else can test
it with nightly..

Comment 5

16 years ago
WFW with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021104
Phoenix/0.4.  Seems unlikely that it will the same as bug 175724 as the
backtrace for that is considerably different to the one posted here.
(Reporter)

Comment 6

16 years ago
Just tested with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021104
Phoenix/0.4

The document is displayed ok if the Phoenix window is the default size (after
fresh install of Phoenix).  When I maximize the window, Phoenix crashes.  My
screen res. is 1280x1024.

Comment 7

16 years ago
WFM with both latest mozilla and phoenix nightlies: Mozilla/5.0 (Windows; U;
Win95; en-US; rv:1.3a) Gecko/20021108 Phoenix/0.4 and Mozilla/5.0 (Windows; U;
Win95; en-US; rv:1.2b) Gecko/20021108

Comment 8

16 years ago
m, do you crash if you try the testcases in bug 145171?

Works for me with latest CVS build on Linux.
(Reporter)

Comment 9

16 years ago
#7 - it's Linux only bug
#8 - doesn't crash with those testcases.. I will try latest nightly on this bug
(Reporter)

Comment 10

16 years ago
still crashes with 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021110 Phoenix/0.4

Comment 11

16 years ago
Michal:

Can you tell us what kind of hardware you are using?
(Reporter)

Comment 12

16 years ago
CPU is AMD Duron 800, I don't know what the MB is.. 128 MB RAM, ATI Rage II
graphics card... anything else?

Updated

16 years ago
Keywords: crash

Comment 13

16 years ago
WFM.
Built from CVS as of 11/25, Xft enabled gcc/g++-3.2 build env...
Could it be the version of gtk+ used perhaps? My version is 2.0.9-1 for Debian
'unstable'.
(Reporter)

Comment 14

16 years ago
Yes, it works with latest nightly..
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021125 Phoenix/0.4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 15

16 years ago
We don't know what fixed this, so it should be marked WORKSFORME.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 16

16 years ago
Mark as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.