Text selected w/mouse from Address bar pulldown gets appended with 'http.'+'.com'

VERIFIED FIXED

Status

()

VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: hartmut, Assigned: hewitt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4; en-US; rv:1.2b) Gecko/20021030 Phoenix/0.4
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4; en-US; rv:1.2b) Gecko/20021030 Phoenix/0.4

If you select an URL from the Address bar pulldown by 
mouse-clicking, it will be prefixed with 'http.' and suffixed 
with '.com', leading to the message 'http.www is not a registered
protocol'.
 
This seems to happen only after typing in an URL by hand.

Reproducible: Always

Steps to Reproduce:
To reproduce:
-start Phoenix
-open the Address bar pulldown
-select an URL with the mouse (you have to have s/th in the 
history list)
-should work
-type an URL into the Adress bar, load it
-select an URL from the pulldown (e.g. http://www.berlingo.net/)


Actual Results:  
- Result here is eg. 'www.http://www.berlingo.net/.com/' plus an 
alert plus an empty tab.


Expected Results:  
Put the text form the pulldown into the Adress Bar 'as is'.
This is a bug in Mozilla. Read how to workaround it here:

http://texturizer.net/phoenix/faq.html#4.10
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
I'm so sorry. I resolved the wrong bug.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Works for me. 

Reporter, you are not using the latest nightly build. Please verify if you can
reproduce it with the latest nightly. (I'm not sure where you got the OS/2
version in the first place though.)
(Reporter)

Comment 4

16 years ago
>Reporter, you are not using the latest nightly build. Please verify if you can
>reproduce it with the latest nightly.

Well, I now tried the latest Windows version, and can confirm that it works there.

>(I'm not sure where you got the OS/2 version in the first place though.)

ftp://ftp.mozilla.org/pub/phoenix/releases/0.4/phoenix-0.4-os2.zip
;-)

So, this seems to be a bug of the OS/2 version. Will report this in the
mozilla.os2 group (one other person has confirmed this behaviour there).
Sorry for the inconvenience.
Confirmed on linux cvs 2002-11-03, fresh profile.

 1. clear url bar, type w/o quotes "google evil goats", hit enter
 2. clear url bar, type w/o quotes "goo", click on the the google search url
    from the popdown

expected: http://www.google.com/search?&q=evil%20goats
actual:   http://www.http.com//www.google.com/search?&q=evil%20goats.org/

The results are slightly different -- instead of .com, the url gets munged from
http://www.google.com/search?&q=evil%20goats to
http://www.http://www.google.com/search?&q=evil%20goats.org/ then resolved to
http://www.http.com//www.google.com/search?&q=evil%20goats.org/

It also opens in a new tab for me -- apparently Phoenix is very confused about
some modifier key things, as the result I get is the same as
Ctrl-Alt-Shift-Enter on the correct url in the urlbar itself would give.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: other → All
toolkit/content/widgets/autocomplete.xml, the onTextEntered method has
          return this.fireEvent("textentered", this.mEnterEvent);

As long as you never press enter in the urlbar in a window, this gives a null
event to browser.js handleURLBarCommand, when clicking on the popdown, and it
works fine. After having pressed enter in the urlbar once, clicking on the
popdown this yields some of bogus event, ctrlaltmetashift-\0, button -1 or so,
and the timestamp looks pretty off too. No idea where it conjures that up from :\

Comment 7

16 years ago
->autocomplete
Assignee: hyatt → hewitt
Component: Toolbars → Autocomplete
*** Bug 209849 has been marked as a duplicate of this bug. ***
*** Bug 210317 has been marked as a duplicate of this bug. ***
Based on dupes --> All/All
Hardware: PC → All
*** Bug 213039 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
noririty says his patch for 177618 fixed this.
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 13

16 years ago
v.
Status: RESOLVED → VERIFIED
QA Contact: asa → davidpjames

Comment 14

16 years ago
*** Bug 215790 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
*** Bug 218217 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.