dependency reports misuse the word "closed".

VERIFIED FIXED in Bugzilla old

Status

()

Bugzilla
Bugzilla-General
P3
normal
VERIFIED FIXED
19 years ago
5 years ago

People

(Reporter: dbaron, Assigned: Terry Weissman)

Tracking

unspecified
Bugzilla old
Other
Other

Details

(Reporter)

Description

19 years ago
The email reports of dependencies are giving the wrong state.  In the report
below, the first dep is VERIFIED/FIXED and the second should be ASSIGNED.  This
is a very recent regression (probably today, perhaps yesterday if I've been
asleep at the wheel...I get lots of Bugzilla mail).  They're shown as [Closed]
below.

From nobody@mozilla.org  Tue Nov  2 18:49:53 1999
Date: Tue, 2 Nov 1999 15:49:41 -0800 (PST)
From: bugzilla-daemon@mozilla.org
To: dbaron@fas.harvard.edu, gerardok@netscape.com
Cc: shaver@mozilla.org, janc@netscape.com
Subject: [Bug 9075] Changed - script halts silently on document.doctype in XML

http://bugzilla.mozilla.org/show_bug.cgi?id=9075

*** shadow/9075 Tue Nov  2 14:32:24 1999
--- shadow/9075.tmp.20601       Tue Nov  2 15:49:41 1999
***************
*** 15,21 ****
  URL: http://www.fas.harvard.edu/~dbaron/dom/test/one-core-xml/Node
  Cc: shaver@mozilla.org, janc@netscape.com
  Summary: script halts silently on document.doctype in XML
! BugsThisDependsOn: 10456[Closed]

  Script halts silently when it encounters document.doctype in XML.  See the
above
  test page.  It halts while processing notNullWarn("document.doctype") .
--- 15,21 ----
  URL: http://www.fas.harvard.edu/~dbaron/dom/test/one-core-xml/Node
  Cc: shaver@mozilla.org, janc@netscape.com
  Summary: script halts silently on document.doctype in XML
! BugsThisDependsOn: 10456[Closed], 15118[Closed]

  Script halts silently when it encounters document.doctype in XML.  See the
above
  test page.  It halts while processing notNullWarn("document.doctype") .
***************
*** 73,75 ****
--- 73,80 ----
  Vidur's bug list is quite large so I don't want to send this to him without
  some more analysis.  I'll bring this up with him offline and get the DOM
  perspective on this.
+
+ ------- Additional Comments From nisheeth@netscape.com  11/02/99 15:49
-------+ This is probably happening because we don't construct the doctype DOM
node in + the XML content sink. I'm marking this bug dependent on bug 15118, the
bug for
+ creating current unused XML content objects.
(Assignee)

Updated

19 years ago
Summary: dependency reports wrong → dependency reports misuse the word "closed".
(Assignee)

Comment 1

19 years ago
It's a feature.

I've changed the format of bug notifications.  Tracking the state of
dependencies to great detail causes too much mail to be sent.  So we just track
whether the dependent bugs are considered to be "open" or "closed".

Now, the unfortunate thing is that the word "Closed" is already used to mean a
particular kind of "non-open" state.  If someone could come up with a word that
means "either resolved or verified or closed", I'll use that instead.
(Reporter)

Comment 2

19 years ago
Shut.
(Reporter)

Comment 3

19 years ago
Another suggestion - use the resolution - fixed, worksforme, duplicate, later,
wontfix, etc... that might be more informative, and it can't change without a
reopen anyway.  However, you should be sure *not* to put the resolution when a
bug is reopened.   (Shouldn't reopening automatically clear the resolution?
leger@netscape.com seems to do that manually every day anyway...).
(Reporter)

Comment 4

19 years ago
BTW, there is also a bug in this new system - ASSIGNED bugs are showing up as
[Closed].  See the text above.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
Ohmigod.  Thank you for noticing the very bad ASSIGNED bug.  Fixed.

And I really really like the suggestion of using the resolution instead of the
word "Closed"!  Thank you for the great idea.  It now works that way.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

19 years ago
Things have been working well lately. Marking verified.
Moving to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: matty
Target Milestone: --- → Bugzilla old
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.