fieldset content is not correctly rendered when its CSS display is toggled

RESOLVED DUPLICATE of bug 177261

Status

()

RESOLVED DUPLICATE of bug 177261
16 years ago
16 years ago

People

(Reporter: martin.honnen, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I have an HTML <fieldset> element containing a <div> element with some <input>
controls. When I set the CSS display of the <div> to none and back to normal
again  there are rendering problems with the fieldset outline and in particular
the <input type="text">. Indeed the rendering is very odd, the inputs have a
border but the content doesn't reside inside the border but sits further up
outside of the border. You can even edit the text there.
This happens with both Netscape 7 as well as Mozilla 1.2b (Gecko/20021027).
IE6 has no problems with the example.
I will attach a test case demonstrating the problem.
I have filed this on Layout: Form Controls, if a layout problem resulting from
script manipulation doesn't fit there then please change the component as needed.
(Reporter)

Comment 1

16 years ago
Created attachment 105078 [details]
test case (click the red minus in the legend to toggle the display to none, then click the plus to set display to block)
marking dup of bug 177261 as its testcase is smaller

*** This bug has been marked as a duplicate of 177261 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.