Closed Bug 1783057 Opened 2 years ago Closed 2 years ago

Pass the correct stream to OnInputStreamReady in nsPreloadedStream

Categories

(Core :: Networking: HTTP, defect, P3)

defect

Tracking

()

RESOLVED FIXED
105 Branch
Tracking Status
firefox105 --- fixed

People

(Reporter: nika, Assigned: nika)

References

Details

(Whiteboard: [necko-triaged])

Attachments

(1 file)

Part forked off of bug 1782181, as it is unlikely to be the cause of that issue, but was found when looking for potential causes.

This is an API requirement of the nsIAsyncInputStream interface, and is
depended on by some streams such as nsMultiplexInputStream.

This is unlikely to have any substantial impact as nsPreloadedStream is only
used in very limited situations, but it may be used in more places in the
future.

Severity: -- → S3
Priority: -- → P3
Whiteboard: [necko-triaged]
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1972fb1c8f02
Pass the correct stream to OnInputStreamReady in nsPreloadedStream, r=necko-reviewers,valentin
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: