Closed Bug 1783102 Opened 2 years ago Closed 2 years ago

Form history autocomplete dropdown doesn't show up in a test site

Categories

(Toolkit :: Form Manager, defect)

defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr91 --- unaffected
firefox-esr102 --- unaffected
firefox103 --- unaffected
firefox104 --- unaffected
firefox105 --- affected

People

(Reporter: dlee, Unassigned)

References

(Regression)

Details

(Keywords: regression)

While testing Bug 1782353, I found out we don't save form history in a test website (Bug 1782353 Comment 4). From a quick test, it seems the lastInteractiveValue (added in Bug 1771806) is empty when a form is submitted.

Reproduce step:

  1. Open the test url and login (see Bug 1782353 Comment 3 and Bug 1782353 Comment 4)
  2. Enter text (test for example) in the "Buscar palabras clave" input field
  3. click "aplicar" button to submit form
  4. Enter text "t" in the "Buscar palabras clave" input field to see whether an autocomplete popup is shown

Hi Serg, could you help take a look at this issue to see whether this is regressed by Bug 1642570?

Flags: needinfo?(sgalich)

Set release status flags based on info from the regressing bug 1642570

Dimi, I'm unable to reproduce it yet. Suggested site is unavailable, so I've tried on https://www.w3schools.com/tags/tryit.asp?filename=tryhtml5_input_autocomplete and history seems to be working just fine. Can you tell what was so special about this site?

Flags: needinfo?(sgalich) → needinfo?(dlee)

Thank you Dimi,

Full details can be found in Bug 1782353 Comment 13, short version is:

Site recreates input after each keypress, to Firefox it looks like user didn't type the value and we ignore it.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
Flags: needinfo?(dlee)
You need to log in before you can comment on or make changes to this bug.