message list clicksort is not "stable" (request for secondary sorts by column click)

VERIFIED DUPLICATE of bug 57898

Status

SeaMonkey
MailNews: Message Display
--
minor
VERIFIED DUPLICATE of bug 57898
16 years ago
13 years ago

People

(Reporter: Christian J. Callsen, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021025
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021025

When using clicksorting on the columns in Mail, the sort is not "stable". With
stable I mean that if I first click on Column "Date" followed by column
"Priority", I would expect a sort by Priority, then Date. And if I click Date,
Flagged, Priority and Unread I would expect a sort by Unread, then by Priority,
then by Flagged, and then by Date.

A typical implementation is to use a stack. When a given column is pressed, it's
first removed from the stack and then pushed on the top. The sorting order is
then top-to-bottom on the stack.

For extra credits, the actual "stack" used for the folder is remembered. And
threading should just be one of the sort keys (over subject?).

Reproducible: Always

Steps to Reproduce:
1. Click on Summary
2. Click on Unread (green light)



Actual Results:  
Sorted by unread only. Unread emails are not sorted by subject.

Expected Results:  
I'd expect to have all Emails that are unread sorted by subject.

Having stable sorts in MailNews (which gets saved) would probably go a long way
to alleviating viewing Mail and making sure the "important" Emails are where you
want them (at top, at bottom).

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: olgam → laurel
Summary: message list clicksort is not "stable" → message list clicksort is not "stable" (request for secondary sorts by column click)
(Reporter)

Comment 1

16 years ago
and tertiary sorts, and quaternary sorts, etc. (just to comment on the addition
to the summary).
I didn't see this as a DUP of anything else. Is it?
Confirming that mailnews thread pane sorting is not stable, linux trunk cvs
2002-10-04. Enhancement->minor, this is a bug imo, and there is no workaround.
Bug 57898 also mentions stable sort, but also all sorts of wacky ui clutter and
modifier keys to confuse people -- so confirming this as a specific bug toward
stable sort without the accessories (even without the threading complication
rather...), instead of marking duplicate of that rfe. Parity-OE per bug 57898
comment 6. Threaded, sorted view: bug 72493
Blocks: 57898
Severity: enhancement → minor
OS: Windows 2000 → All

Comment 3

16 years ago
IMO, this is a clear dup.
And, threading does matter even in this bug. Many people will want to have
"stable sort" exactly for threading.

*** This bug has been marked as a duplicate of 57898 ***
No longer blocks: 57898
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verified as a duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.