Adding a new bookmark with a previous-bookmarked URL causes incorrect naming of all bookmarks

VERIFIED DUPLICATE of bug 177501

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 177501
16 years ago
15 years ago

People

(Reporter: phil, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I'm using the nightly build (phoenix-win32.zip) dated Nov 4 12:32

When you bookmark a URL that has already been bookmarked, all the existing
bookmarks with that URL receive the new name, and the new bookmark receives the
default name.

In addition, if you try to bookmark the same URL twice in the same folder, you
end up with only one bookmark (with the new name) in that folder. Based on the
previous paragraph I suspect that the bookmark may be original renamed, with the
new one having been discarded, but that's just a guess.

Steps to observe this bug:

#1. Bookmark a page (in any location, with any name).

#2. Bookmark the same page (in a different location, with a different name.)

At this point bookmark 2 has the default name for the bookmarked page, and
number 1 has been renamed with the name you entered for the second bookmark.

#3. Repeat as for #2

Now both 1 and 2 have the name entered for #3, and #3 has the default name.

#4. Bookmark the page again (with yet another name) in one of the folders you
already assigned one of the previous bookmarks to.

At this point you have the same number of bookmarks as you had at the previous
stage, but all of them have the name entered for #4.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 177501 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
hmmm... curiously, the Bookmark Manager disagrees with what I've just described.
It looks as if all copies of the bookmark have the default page name when viewed
in the Bookmark Manager.

Ah... If you carry out the above steps with the Manager already open, then it
will also exhibit the same behaviour as previously described, but if you close
and re-open the Manager then all bookmarks have been re-named to the default
page name.

I forgot to mention that I wondered if this was a duplicate of bug #177501
<URL:http://bugzilla.mozilla.org/show_bug.cgi?id=177501>, but a comment there
says that the Phoenix bookmark code is now separate to Mozilla's. Perhaps both
still share this issue, though?
(Reporter)

Comment 3

16 years ago
After noting the Bookmark Manager behaviour, I checked to see what happened when
closing and re-starting Phoenix itself, and it shares the same behaviour as the
Manager -- all the bookmarks now have the default page name for that URL.

Obviously there is some kind of name caching issue which causes the
currently-displayed name to differ from the stored name, and when the bookmark
file is re-read the stored names (which are also wrong :) are shown.

I guess there are three potentially-separate bugs then:

1) The caching / incorrect-renaming of existing copies of bookmarks
2) The incorrect naming of a previously bookmarked page to the default name for
the page
3) The inability to bookmark the same page twice in a single folder

(Although (3) is probably a side-effect of (2), come to think of it -- it was
just less obvious that this was the case initially, because of (1)!)

Comment 4

15 years ago
Mass verifiying old duplicates.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.