Closed Bug 1783452 Opened 6 months ago Closed 6 months ago

Option to disable "QuickActions" specific buttons or whole feature is not present in Firefox's Settings

Categories

(Firefox :: Address Bar, defect)

Firefox 105
Desktop
All
defect

Tracking

()

VERIFIED FIXED
105 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox-esr102 --- unaffected
firefox103 --- unaffected
firefox104 --- unaffected
firefox105 --- verified

People

(Reporter: Virtual, Assigned: daleharvey)

References

(Blocks 3 open bugs)

Details

(Keywords: nightly-community, ux-control, ux-minimalism)

Attachments

(2 files, 1 obsolete file)

Option to disable "QuickActions" specific buttons or whole feature is not present in Firefox's Settings.

Steps to reproduce:

  1. Open latest Mozilla Firefox Nighty 105.0a1 (2022-08-05) (64-bit)
  2. Select Address Bar
  3. Notice 5 new buttons ("View Add-ons", "View Bokmarks", "Clear History", "Open Downloads", "Open Inspector")
  4. Open Firefox's Settings and look for option to hide them from there
  5. Notice that option to disable "QuickActions" specific buttons or whole feature is not present in Firefox's Settings

Observed results:
Option to disable "QuickActions" specific buttons or whole feature is not present in Firefox's Settings.

Expected results:
Option to disable "QuickActions" specific buttons or whole feature is present in Firefox's Settings.

Blocks: 1783612
Severity: -- → S3

Since there already is an issue handling the enable/disable the feature, I'll also add that the about:preferences#search option to enable/disable the feature should also remove/hide it from the about:preferences#search / Search shortcuts.
Also, given that this feature will be first an experiment, maybe also a different pref to enable/disable the quickactions UI about:preferences#search option.

Maybe also telemetry on enable/disable?

Dale, can you take a look at this issue and clarify what are the expectancies in regards to this topic?

Flags: needinfo?(jteow)

Adrian, I'm going to needsinfo Dale because he's been the main engineer on this project.

Flags: needinfo?(jteow) → needinfo?(dharvey)

Adrian, thanks yeh that sums up what the enabling + setting options should look like. This slipped through the crack a little as the settings have been discussed and specced but should have been filed and probably implemented before enabling, but will use this bug to implement them, thanks.

Assignee: nobody → dharvey
Blocks: 1782974
No longer blocks: 1778132
Flags: needinfo?(dharvey)

Adding the UX spec for the option.

Attachment #9289828 - Attachment description: Bug 1783452 - Add section in preferences to enable/disable QuickActions. r=Standard8 → Bug 1783452 - Add section in preferences to enable/disable QuickActions. r=adw
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a40754091a30
Add section in preferences to enable/disable QuickActions. r=adw,fluent-reviewers,preferences-reviewers,flod,mstriemer
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch

Verified the addition of option to disable the QuickActions functionality in about:preferences#privacy / Address bar with 105.0a1 (2022-08-22) on Windows 10, Ubuntu 22.04 and Mac 11. Spinned off bug 1786297 for the follow-up work.

Status: RESOLVED → VERIFIED
OS: Windows 7 → All
Hardware: x86_64 → Desktop
Attachment #9289828 - Attachment is obsolete: true
See Also: → 1786702
Blocks: 1790406
You need to log in before you can comment on or make changes to this bug.