Closed Bug 1783552 Opened 2 months ago Closed 2 months ago

"Download the rest of the message" broken in 102.1.1 - TypeError: this.runningUri.SetUrlState is not a function 2 Pop3Client.jsm:132:21

Categories

(MailNews Core :: Networking: POP, defect, P1)

Thunderbird 102

Tracking

(thunderbird_esr102 fixed, thunderbird104 fixed)

RESOLVED FIXED
105 Branch
Tracking Status
thunderbird_esr102 --- fixed
thunderbird104 --- fixed

People

(Reporter: b1, Assigned: rnons)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/104.0.5112.81 Safari/537.36 Edg/104.0.1293.47

Steps to reproduce:

Selected to download headers only, when downloading rest of the message:
TypeError: this.runningUri.SetUrlState is not a function 2 Pop3Client.jsm:132:21

About time to have this covered in a test or testplan

Blocks: tb102found
Flags: needinfo?(remotenonsense)
Keywords: regression

Tested on a GMX account.

Confirming this regression in 102.1.1 for GMX and Yahoo accounts

Status: UNCONFIRMED → NEW
Ever confirmed: true
Regressed by: 1777765
Severity: -- → S2
Priority: -- → P1
Summary: "Download the rest of the message" broken in 102.1.1 → "Download the rest of the message" broken in 102.1.1 - TypeError: this.runningUri.SetUrlState is not a function 2 Pop3Client.jsm:132:21

Add test_Pop3Channel.js.

Assignee: nobody → remotenonsense
Status: NEW → ASSIGNED
Flags: needinfo?(remotenonsense)
Duplicate of this bug: 1783878

Users never fail to surprise us do they? The user experience of this feature is terrible by any means. But of course, if there's a setting in the UI, some people will use it.

Target Milestone: --- → 105 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/15dcf85c699e
Fix downloading partial message in pop3-js. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Comment on attachment 9289006 [details]
Bug 1783552 - Fix downloading partial message in pop3-js. r=mkmelin

[Triage Comment]
Approved for beta.

Attachment #9289006 - Flags: approval-comm-beta+

Comment on attachment 9289006 [details]
Bug 1783552 - Fix downloading partial message in pop3-js. r=mkmelin

[Triage Comment]
Approved for comm-esr102.

Attachment #9289006 - Flags: approval-comm-esr102+
You need to log in before you can comment on or make changes to this bug.