Closed Bug 1783565 Opened 2 months ago Closed 2 months ago

Enable more ESLint rules for netwerk

Categories

(Core :: Networking, task, P3)

task

Tracking

()

RESOLVED FIXED
105 Branch
Tracking Status
firefox105 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

(Blocks 1 open bug)

Details

(Whiteboard: [necko-triaged])

Attachments

(6 files)

There's still a few rules that are disabled in netwerk that we want to enable. This will help with consistency with the rest of the tree, as well as helping to show up potential issues in new code.

Summary: Enable more ESLint rulse for netwerk → Enable more ESLint rules for netwerk
Keywords: leave-open
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7e11b0d6e731
Enable ESLint rules for no-arbitrary-setTimeout, no-define-cc-etc and consistent-return on netwerk/. r=dragana,necko-reviewers
https://hg.mozilla.org/integration/autoland/rev/cc2d5eaf69d2
Enable ESLint rules no-eval, no-nested-ternary, no-throw-literal for the rest of netwerk. r=dragana,necko-reviewers
https://hg.mozilla.org/integration/autoland/rev/3523c3cede7d
Enable ESLint rule no-redeclare on the rest of netwerk. r=dragana,necko-reviewers
https://hg.mozilla.org/integration/autoland/rev/289d233f1266
Enable ESLint rule no-global-assign for the rest of netwerk. r=dragana,necko-reviewers

Bah, xpcshell-tests didn't run on my try push :( Will take a look and re-fix.

Flags: needinfo?(standard8)
Regressions: 1783727
No longer regressions: 1783727
Severity: -- → N/A
Priority: -- → P3
Whiteboard: [necko-triaged]
Depends on: 1784699
See Also: → 1760062
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7cc59ef5a163
Enable ESLint rules for no-arbitrary-setTimeout, no-define-cc-etc and consistent-return on netwerk/. r=dragana,necko-reviewers
https://hg.mozilla.org/integration/autoland/rev/44754d53368c
Enable ESLint rules no-eval, no-nested-ternary, no-throw-literal for the rest of netwerk. r=dragana,necko-reviewers
https://hg.mozilla.org/integration/autoland/rev/2bca60bdf1d8
Enable ESLint rule no-redeclare on the rest of netwerk. r=dragana,necko-reviewers
https://hg.mozilla.org/integration/autoland/rev/25a79e2dc30a
Enable ESLint rule no-global-assign for the rest of netwerk. r=dragana,necko-reviewers
https://hg.mozilla.org/integration/autoland/rev/4303f3ec286a
Set ESLint rule no-shadow to warning for where it is turned on in netwerk. r=dragana
Pushed by ctuns@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f7ffff73891a
Fix ESlint issue in netwerk/test/unit/head_servers.js due to consistent-return). CLOSED TREE
Status: NEW → RESOLVED
Closed: 2 months ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch
You need to log in before you can comment on or make changes to this bug.