Closed Bug 1783870 Opened 2 years ago Closed 2 years ago

Quickactions should redirect to about: pages if already opened

Categories

(Firefox :: Address Bar, defect)

Firefox 105
defect

Tracking

()

VERIFIED FIXED
106 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox-esr102 --- unaffected
firefox103 --- unaffected
firefox104 --- unaffected
firefox105 --- wontfix
firefox106 --- verified
firefox107 --- verified

People

(Reporter: phorea, Assigned: daisuke)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Note
This issue applies for all the about: pages bellow that have a QuickAction operation:
View Add-ons -> about:addons
Open Downloads -> about:downloads
View Logins -> about:logins
Open Settings -> about:preferences

Found in

  • 105.0a1 2022-08-09

Affected versions

  • latest Nightly 105.0a1 2022-08-09

Affected platforms

  • Win 10 64-bit

Steps to reproduce

  1. Open about:preferences
  2. Focus address bar and type options -> Open Settings quick action button is shown
  3. Select the Open Settings quick action button

Expected result

  • about:preferences page is reloaded or loaded in case a subsection of it was opened at step 1 (eg: about:preferences#search)
  • In case the target page is already opened, QuickAction should move the focus to the corresponding tab. This is already implemented for all the internal pages when accessed from Hamburger Menu / Menu Bar or Keyboard Shortcuts.

Actual result

  • about:preferences is opened in a new tab
  • Lots of duplicate tabs can be opened this way

Regression range

  • Not a regression
Has STR: --- → yes
Assignee: nobody → daisuke
Status: NEW → ASSIGNED
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/556e89a411bf
Switch to tab that is already opening the same about page. r=daleharvey
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 106 Branch
Flags: in-testsuite+

Open Downloads -> about:downloads and View Logins -> about:logins are simple enough pages: they either open or switchto if already open . On already open about:downloads/about:logins, we switch tab, which is expected.

View Add-ons -> about:addons and Open Settings -> about:preferences complicate a bit the problem, since both have different states of the page:

  • about:preferences: we curently diferentiate betwen about#preferences and about:preferences#search, which we consider different pages hence no switch betwen them.

  • about:addons: we don't differentiate betwen the 4 states of the about:addons page and we switch to already open -> although we split them into different quick actions, maybe align about:addons with how about:preferences# behaves? Spin a follow-up bug for this?

Flags: needinfo?(dharvey)
Flags: needinfo?(daisuke)

Hi Adrian, I'm sorry for my delay.

In my opinion, for both about:addons and about:preferences, it better to select the tab opening currently, and keep the status as it is.
For example, for about:addons, if plugin section of about:addons is opening in a tab, just select the tab, not load any.
Likewise, for about:preferences, if about:preferences#privacy is opening a tab, just select the tab, not load any.
But, I'd like to hear Dale's opinion as well.

Flags: needinfo?(daisuke)

Yup I agree with that

Flags: needinfo?(dharvey)
Blocks: 1789322

Thanks! Filed bug 1789322.

Verified as fixed using Firefox 106 beta 2 and latest Nightly 107.0a1 2022-09-22.

Status: RESOLVED → VERIFIED
No longer blocks: 1838617
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: